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There are three categories of T3 Professional Development, each with a unique set of learning objectives. 
This workshop is focused on content knowledge, and its objectives are as follows: 
 

Content Knowledge 
 Emphasis on content with technology as support 
 Addresses critical, tough-to-teach topics and new content standards for CCSS or TEKS 

• I have a deeper understanding of the mathematics and science in my content area, 
and I am aware of the shifts in content that affect what I teach. 

• I can design opportunities for students to use technology as a tool to deepen their 
understanding of mathematics and science. 

• I can locate and download TI activities that align to my standards. 
• I can describe the role technology should play in the successful implementation of my 

standards, and I can implement a vision of a classroom where students routinely use 
technology to engage in the practice and content standards. 

 
 

Workshops focused on instructional practices and technology integration have the following objectives: 
 

Instructional Practices 
 Emphasis on classroom practices with technology as a tool to enhance student learning 
 Models CCSS, TEKS, and NGSS tasks using in-depth discussions, reflective practices, and 

essential technology skills 
• I can demonstrate the importance of teacher actions for students’ engagement in the 

Practices, and I can take actions that will enable students to become mathematical 
and scientific practitioners. 

• I can describe the role that technology should play in the successful implementation 
of my standards, and I can implement a vision of a classroom where students 
routinely use technology to engage in practice and content standards. 

• I can design tasks for students to employ the Practices, using technology as a tool to 
deepen their understanding of mathematics and science. 

• I can ask questions designed to make student thinking visible – to push them to think 
about connections, make comparisons, or probe their understanding. 

 

Technology Integration 
 Emphasis on learning to use TI technology, with broad “how-to” coverage highlighting a 

wide range of features 
 Subject/content-focused training on appropriate usage of TI technology in the classroom 

• I am comfortable with essential technology skills for exploring math and science content. 
• I can design opportunities for students to use technology as a tool to deepen their 

understanding of mathematics and science. 
• I can locate and download TI activities that align to my standards. 
• I can describe the role technology should play in the successful implementation of my 

standards, and I can implement a vision of a classroom where students routinely use 
technology to engage in the practice and content standards. 



   Exploring Common Core Topics in Statistics with  
TI-Nspire™ Technology 

©2014 Texas Instruments Incorporated 1 education.ti.com 

Day One Page # 

1. TI-Nspire™ CX Family Overview 5 

2. Interpreting Linear Models 9 

3. Exploring the Normal Curve Family 25 

4. Empirical Rule 37 

5. Sampling Distributions 49 

6. Conditional Probability 63 

Appendix  

A. TI-Nspire™ CX Family Overview 77 

B. Getting Started with the TI-Nspire™ Teacher Software 79 

C. The Content Workspace 87 

D. TI-Nspire™ Skill Builder 91 

E. TI-Nspire™ Keypad Shortcuts 107 

F. Checking and Updating the Operating System 111 

G. Transferring Documents Between Handhelds 113 

H. Transferring Documents Using the TI-Nspire™ Teacher Software 115 

I. The Press-to-Test Feature 117 

J. The Common Core Mathematical Practices 119 

K. TI Technology Exam Acceptance 121 

 



 

This page intentionally left blank 

 



 TI-Nspire™ CX Family Overview 
TI PROFESSIONAL DEVELOPMENT 

 

 

©2014 Texas Instruments Incorporated 1 education.ti.com 

Activity Overview 
In this activity you will become familiar with the most commonly used keys on the TI-Nspire™ CX family of 
handhelds. 
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Activity Overview 
In this activity, you will become familiar with the layout of the TI-Nspire™ CX family of handhelds. 
 
 
 

Step 1:  

Locate the Touchpad. The Touchpad is used to navigate the cursor around the screen. 
What appears in the center of the Touchpad? 

Step 2:  

Locate the keys to the left of the Touchpad. How do some of these keys compare in name 
and location to keys on a computer keyboard? 

Step 3:  

Note the light blue or yellow color of the commands that appear above many of the keys. 
Which key do you push to access the light blue or yellow options on the key pad? 

Step 4:  

Many of the traditional shortcut keys used with computer software are available on a TI-Nspire 
handheld. For example, / C and / V are used to “copy” and “paste,” respectively. 

Step 5:  

Note the colors of various keys and the location of the alpha keys. What do you notice about the 
arrangement of the keys? 

Step 6:  

Where are the buttons for adding, subtracting, multiplying, and dividing located? 

Step 7:  

Press c to turn on the handheld. If the Home Screen is not 
displayed, press c again. Use the e key to move to each 

of the Home Screen options. Note the applications available on 
the bottom row of the Home Screen. 

  

7



 TI-Nspire™ CX Family Overview                              
TI PROFESSIONAL DEVELOPMENT 

 

 

©2014 Texas Instruments Incorporated 2 education.ti.com 

Step 8:  

Note the Scratchpad options available on the left hand side of 
the screen and the icon in front of the Scratchpad. Locate the 
Scratchpad key on the handheld.  

 

Step 9:  

Select Settings > Status from the Home Screen. You will find 
the available memory and the battery status noted on the screen. 
Press d or press a to choose OK to exit the Status screen. 

 

 

Step 10:  

Select Settings > Document Settings. Explore the options 
available. Press d or, using the Touchpad, move to OK and 
press a to exit the Document Settings menu. 

 

 

Step 11:  

From the Home Screen, select New Document to start a new 
document. If prompted to save the current document, select No. 
Choose Add Calculator. This Calculator page is the first page of 
the first problem in this new document. The tab indicating 
problem one, page 1 (1.1) is displayed in the top left corner of 
the screen. 

 

 

Step 12:  

Using the Touchpad, move the cursor to the icon to the left of the 
red X in the top right hand corner of the screen. What information 
is provided? 
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Open the TI-Nspire™ document Interpreting_Linear_Models.tns. 
 
In this activity, you will create a scatter plot of mean pulse rates 
before and after exercise and explore the relationship between the 
two variables. 

 

 
Jackie’s class has been studying health and nutrition. One of the students read an article about pulse 
rates before and after-exercise. The students wondered whether you could predict their after-exercise 
pulse rates from their before-exercise pulse rates. The class measured their pulse rates before and 
after exercise for five days. The data in the "before" columns represent the mean pulse rate for the five 
days at the beginning of class for a student. The entry in the corresponding "after" column represents 
the mean pulse rate of that student after one minute of doing jumping jacks. 
Note: All of the students in Jackie’s class are aged 16 or 17.  
 

 Pulse Beats/Min 
before-

exercise 

Pulse Beats/Min 
after-exercise 

  Pulse Beats/Min 
before-exercise 

Pulse Beats/Min 
after-exercise 

1 86 164  16 73 144 
2 88 164  17 73 136 
3 75 140  18 79 145 
4 88 160  19 79 141 
5 64 137  20 86 150 
6 84 136  21 98 156 
7 85 154  22 74 136 
8 93 140  23 76 122 
9 93 164  24 96 160 
10 86 156  25 92 145 
11 87 153  26 58 140 
12 96 154  27 84 148 
13 72 145  28 92 150 
14 67 134  29 88 141 
15 62 129  30 80 130 

 

 
Move to page 1.2. 
 
The data from the table have been entered into a Lists & 
Spreadsheet page. 
 

Press / ¢ and / ¡ to 

navigate through the lesson. 
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Move to page 1.3. 
 
Page 1.3 is a Data & Statistics page. To graph the scatter plot, move the cursor to the “Click to add 
variable” message near the lower center of the screen. Press x to display the variables. Select 

the independent variable. 

Move the cursor to the middle of the left side of the screen. When the “Click or Enter to add 
variable” message appears, press x to display the variables. Select the dependent variable. 

 
Select Menu > Analyze > Add Movable Line. Transform the movable line until it fits the trend in 
the data well. 
 

• To rotate the line, move the cursor to the graph of the line near the edge of the graph 
screen. When the rotation symbol (é) appears, press / x to grab the line. Use the 
Touchpad to rotate the graph. When finished, press x or d. 

• To translate the line, move the cursor to the graph of the line in the center of the screen. 
When the translation symbol (ö) appears, press / x to grab the line. Use the 
Touchpad to translate the graph. When finished, press x or d. 

 
1. a. What is the equation of your movable line? 
   

 
b. Interpret the slope of your line in terms of the mean pulse rates. 

 
 

c. Is the y-intercept of your line meaningful? Why or why not? 
 

 

d. Give the coordinates of a data point that is very close to the line. What after-exercise pulse rate 
does your line predict for the person whose data point you identified? How far off is this 
prediction?  

 
 

e. Give the coordinates of a data point that is not very close to the line. What after-exercise pulse 
rate does your line predict for the person whose data point you identified? How far off is this 
prediction? 
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2. Select Menu > Analyze > Residuals > Show Residual Squares. 
a. What does the length of the side of each square represent? 

 
 

b. What does the area of each residual square represent? 
 
 

c. Record the value of the sum of squares for your movable line. 
 
 

d. Move your movable line to several different locations. What do you observe about the 
residual squares and the sum of squares of the residuals? 
 
 

e.  Change your movable line until the sum of the squares of the residuals is approximately 
9,000. Then change the movable line until the sum of the squares is approximately 2,500. 
What do you observe about the relationship between the sum of the squares of the 
residuals and the fit of the movable line? 

 

 

f. Change your movable line until you have the smallest value that you can determine for the 
sum of the squares of the residuals. What is that sum of squares? 

 

 

3. Select Menu > Analyze > Residuals > Hide Residual Squares. Move your movable line so that it 
has the same equation as your answer to Question 1a. Then select Menu > Analyze > Residuals 
> Show Residual Plot. 

 
a.  In the top work area, move the cursor over the point you identified in Question 1e as a point 

that is not very close to the line. What do the coordinates of the point represent? 
 

 

b.  Click on this point, and observe the associated point in the residual plot. Move the cursor 
over the point in the residual plot to display the coordinates. What do the coordinates of the 
point in the residual plot represent?  
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c.  Describe any pattern you see in the residual plot. What does this indicate about your 
movable line? 

 
 
4. In the top work area, move your movable line to different locations, and observe how the 

residual plot changes. (Note: You might have to select Menu > Window/Zoom > Zoom – Data 
in order to see all of the residuals.) 
a. Find a line where the residual plot has a pattern. Describe the pattern and the relationship 

between the movable line and the pulse rate data. 
 

 

 

b.  Find a line where the residual plot doesn’t have a pattern. Compare your movable line to the 
lines of several other students. Whose line seems to best fit the trend in the data? Explain your 
thinking. 

 

 

Move to page 1.4. 
 
On page 1.4, graph the same scatter plot that you graphed on page 1.3.  
 
A linear least squares fitting technique can be used to model data that has a linear trend. Graph the 
least squares regression line by selecting Menu > Analyze > Regression > Show Linear (mx + b). 
 

5. Select Menu > Analyze > Residuals > Show Residual Plot to display the residual plot for the 
regression line.  
a.  Describe the residual plot for the regression line. 

 

Select Menu > Analyze > Residuals > Hide Residual Plot to remove the residual plot. 
 
Select Menu > Analyze > Residuals > Show Residual Squares to display the sum of the 
squares of the residuals for the regression line.  
 
b. The least squares linear regression line is the line that minimizes the sum of the squares of 

the residuals. Given your previous exploration of movable lines and residual squares, does 
this statement seem to be true? Explain your answer. 
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c. Interpret the slope of the least squares regression equation in terms of the mean pulse 
rates. How does your answer compare to your answer to Question 1b? 

 

 

d. According to some experts, the maximum pulse rate is 220 minus your age, and a healthy 
pulse rate during, or just after, exercise should be about 60-80% of this number. Assume 
that a 16 year-old student has a before-exercise mean pulse rate of 68 beats per minute. 
How does the after-exercise mean pulse rate predicted by the regression equation 
compare to the after-exercise pulse rate range described by the experts? 

 
 
 

Note: To use the regression equation to predict an after-exercise mean pulse rate, press / 
~, and select Add Calculator to add a Calculator page. Press h and select 

stat.regeqn. In the parentheses, enter a value for the before-exercise mean pulse rate, 
and press ·. 
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Math Objectives 
• Students will model a linear relationship between the independent 

and dependent variables in a data set and analyze graphical 
representations of the residuals.   

• Students will recognize that if a linear model is a good fit for the 
data, the residual plot will be randomly scattered about the 
horizontal axis with no obvious curvature or trend. 

• Students will model with mathematics (CCSS Mathematical 
Practices). 

 
Vocabulary 
• independent variable 
• dependent variable 
• scatter plot 
• slope 
• least squares regression line 
• residual 

 
About the Lesson 
• This lesson involves graphing a scatter plot and fitting a line to 

mean pulse rate data collected before and after exercise. 
• As a result, students will: 

• Fit a movable line to a scatter plot of mean pulse rates before 
and after exercise. 

• Interpret the slope and y-intercept of the line in terms of the 
pulse rates. 

• Display and interpret the sum of squares of residuals. 
• Identify large residuals from the scatter plot and movable line 

and from the residual plot. 
• Graph and interpret the least squares regression line and 

corresponding residual squares and residual plot. 

 

TI-Nspire™ Navigator™ System 
• Use Class Capture to examine different lines used by students to 

model the trend of the data. 
• Use Live Presenter to display graphs of residual squares and 

residual plots. 
• Use Quick Poll to assess student understanding. 

 
 
TI-Nspire™ Technology Skills:  
• Download a TI-Nspire 

document 
• Open a document 
• Move between pages 
• Grab and drag a line 
 
Lesson Files: 
Student Activity 
• Interpreting_Linear_Models_

Student.doc 
• Interpreting_Linear_Models_

Student.pdf 
 

TI-Nspire document  
• Interpreting_Linear_Models. 

tns 
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Discussion Points and Possible Answers 
 

Tech Tip: Using the TI-Nspire™ Teacher Software, you can copy data 
from a spreadsheet or table and paste it into a Lists & Spreadsheet 
application. In the Lists & Spreadsheet page, move the cursor to Cell A1, 
and press ctrl+v to paste the data into the spreadsheet. Note that the 
name for each list must be entered into the top row of each column. 

 
Jackie’s class has been studying health and nutrition. One of the students read an article about pulse 
rates before and after-exercise. The students wondered whether you could predict their after-exercise 
pulse rates from their before-exercise pulse rates. The class measured their pulse rates before and 
after exercise for five days. The data in the "before" columns represent the mean pulse rate for the five 
days at the beginning of class for a student. The entry in the corresponding "after" column represents 
the mean pulse rate of that student after one minute of doing jumping jacks. 
Note: All of the students in Jackie’s class are aged 16 or 17.  
 

 Pulse Beats/Min 
before exercise 

Pulse Beats/Min 
after exercise 

  Pulse Beats/Min 
before exercise 

Pulse Beats/Min 
after exercise 

1 86 164  16 73 144 
2 88 164  17 73 136 
3 75 140  18 79 145 
4 88 160  19 79 141 
5 64 137  20 86 150 
6 84 136  21 98 156 
7 85 154  22 74 136 
8 93 140  23 76 122 
9 93 164  24 96 160 
10 86 156  25 92 145 
11 87 153  26 58 140 
12 96 154  27 84 148 
13 72 145  28 92 150 
14 67 134  29 88 141 
15 62 129  30 80 130 

 

 
Move to page 1.2. 
 
The data from the table have been entered into a Lists & 
Spreadsheet page. 
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Move to page 1.3. 
 
Page 1.3 is a Data & Statistics page. To graph the scatter plot, 
move the cursor to the “Click to add variable” message near the 
lower center of the screen. Press x to display the variables. 

Select the independent variable. 

Move the cursor to the middle of the left side of the screen. When 
the “Click or Enter to add variable” message appears, press x 
to display the variables. Select the dependent variable. 

 
Note: Students can also press e to display the variables after 

moving to the Data & Statistics page. 

 

 
 

Select Menu > Analyze > Add Movable Line. Transform the 
movable line until it fits the trend in the data well. 
 

• To rotate the line, move the cursor to the graph of the 
line near the edge of the graph screen. When the 
rotation symbol (é) appears, press / x to grab 

the line. Use the Touchpad to rotate the graph. When 
finished, press x or d.  

• To translate the line, move the cursor to the graph of the 
line in the center of the screen. When the translation 
symbol (ö) appears, press / x to grab the line. 

Use the Touchpad to translate the graph. When finished, 
press x or d. 

 

 
 

 

1. a. What is the equation of your movable line? 
 

Sample Answer: Answers will vary. One example: m1(x) = 1.32 x + 38 
 

b. Interpret the slope of your line in terms of the mean pulse rates. 
 

Sample Answer: Answers will vary. The slope value given in the Sample Answer for 
Question 1a is 1.32. If the before-exercise mean pulse rate increased by 10 beats per 
minute, the after-exercise mean pulse rate would increase by about 13 beats per minute.  
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c. Is the y-intercept of your line meaningful? Why or why not? 
 

Sample Answer: The y-intercept is not meaningful because the x-coordinate of the  
y-intercept would represent a mean pulse rate before exercise of 0 beats per minute. 

  
d. Give the coordinates of a data point that is very close to the line. What after-exercise pulse rate 

does your line predict for the person whose data point you identified? How far off is this 
prediction?  

 
Sample Answer: The point (74, 136) is close to my line. The line predicts a mean 
after-exercise pulse rate of almost 136 beats per minute, while the observed pulse 
rate was 136 beats per minute. 

 
e. Give the coordinates of a data point that is not very close to the line. What after-exercise pulse 

rate does your line predict for the person whose data point you identified? How far off is this 
prediction? 

 
Sample Answer: The point (93,140) is pretty far from the line. The movable line predicts a 
mean after-exercise pulse rate of approximately 160 beats per minute, which is a difference 
of 20 beats per minute. This difference is larger than many of the other differences between 
the observed and the predicted values.  

 
Tech Tip: Moving the cursor over a point in a scatter plot will display the 
coordinates of the point. The vertical axis scale can be used to estimate an 
after-exercise pulse rate predicted by a student’s movable line. 

 

TI-Nspire Navigator Opportunity: Class Capture and Live Presenter 
See Note 1 at the end of this lesson. 

 
2. Select Menu > Analyze > Residuals > Show Residual 

Squares. 
a. What does the length of the side of each square represent? 

 
Sample Answer: The length is the absolute value of the 
difference between the actual after-exercise mean pulse rate 
and the after-exercise mean pulse rate predicted by the 
movable line. 
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Teacher Tip: Be sure that students understand that the difference in the  
y-value of a data point (beatsmin_before, observed) and the y-value of the 
ordered pair predicted by the mathematical model (beatsmin_before, 
predicted) is the value of the residual. Consequently, a residual might be a 
negative or a positive number and its absolute value is the vertical distance 
from the data point to the linear model.  

 
b. What does the area of each residual square represent? 

 
Sample Answer: The area of a residual square is the square of the value of the residual 
for that particular square. 

 
c. Record the value of the sum of squares for your movable line. 
 

Sample Answer: 3392.48 square units 
 

d. Move your movable line to several different locations. 
What do you observe about the residual squares and the 
sum of squares of the residuals? 

 
Sample Answer: As the movable line changes, the 
residual squares change, and the sum of the squares of 
the residuals change. 

 
 

e.  Change your movable line until the sum of the squares of the residuals is approximately 
9,000. Then change the movable line until the sum of the squares is approximately 2,500. 
What do you observe about the relationship between the sum of the squares of the 
residuals and the fit of the movable line? 

 
Sample Answer: When the value of the sum of squares is larger, the line does not fit the trend 
in the data as well. When the value of the sum of squares is smaller, the line is a better fit. 

 
f. Change your movable line until you have the smallest 

value that you can determine for the sum of the squares 
of the residuals. What is that sum of squares? 
 

Sample Answer: Sum of Squares = 2136.27 square units 
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Teacher Tip: Be sure that students understand that when they change the 
line to try to locate a smaller value for the sum of the residuals squares, 
they are also trying to determine a line that is as close to all of the data 
points as possible. The differences between the observed and expected 
values are reduced. 

3. Select Menu > Analyze > Residuals > Hide Residual Squares. 
Move your movable line so that it has the same equation as your 
answer to Question 1a. Then, select Menu > Analyze > 
Residuals > Show Residual Plot. 

 

a.  In the top work area, move the cursor over the point you 
identified in Question 1e as a point that is not very close 
to the line. What do the coordinates of the point 
represent? 

 
Sample Answer: The point (93,140) represents a before-
exercise mean pulse rate of 93 beats per minute and an 
after-exercise mean pulse rate of 140 beats per minute. 

 

 

b.  Click on this point, and observe the associated point in 
the residual plot. Move the cursor over the point in the 
residual plot to display the coordinates. What do the 
coordinates of the point in the residual plot represent?  

 
Sample Answer: The coordinates of the associated 
point in the residual plot are (93,-20.95). This indicates 
that for a before-exercise mean pulse rate of 93 beats 
per minute, the movable line predicts an after-exercise 
mean pulse rate that is 20.95 or about 21 beats greater 
than the observed number of beats (140). The observed 
value is less than the predicted value. Therefore, the 
sign of the residual is negative. 

 

 

Tech Tip: To deselect one or more points, click in an empty location in the 
screen. 
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c.  Describe any pattern you see in the residual plot. What does this indicate about your movable 
line? 

 
Sample Answer: For the movable line shown, the residuals for the lowest before-exercise 
mean pulse rates are positive – the line under-predicts these after-exercise mean pulse rates. 
Most of the residuals for the largest before-exercise mean pulse rates are negative – the line 
over-predicts these after-exercise mean pulse rates. There is a somewhat linear pattern in the 
residual plot. The movable line does not fit the data well. 

 
Teacher Tip: Depending on the students’ movable lines, there might or 
might not be a pattern in their residual plots. If the points in a residual plot 
are randomly dispersed around the horizontal axis, the mathematical 
model is likely appropriate for the data. Display a movable line for which 
the residuals have a pattern (perhaps they appear very linear or all positive 
or all negative), and help students understand that this suggests that this 
particular movable line is not a good fit for the data. Ask students to think 
about how they might move the line in terms of slope and y-intercept to 
remove a pattern in the residual plot. This can reinforce the relationship 
between the two representations—the equation and the line. The pattern 
shown in the sample answers for Question 3 suggest that the slope of the 
movable line should be smaller for a better fit.  

 
4. In the top work area, move your movable line to different locations and observe how the 

residual plot changes. (Note: You might have to select Menu > Window/Zoom > Zoom – Data 
in order to see all of the residuals.) 
a. Find a line where the residual plot has a pattern. 

Describe the pattern and the relationship between the 
movable line and the pulse rate data. 
 
Sample Answer: Students might describe a residual plot 
where the residuals are nearly all negative, which indicates 
that the movable line was above most of the data points.  

b.  Find a line where the residual plot doesn’t have a pattern. Compare your movable line to the 
lines of several other students. Whose line seems to best fit the trend in the data? Explain your 
thinking. 

 
Sample Answers: Reasons for selecting the "best fit" line for the data might include equal 
number of positive and negative residuals or no pattern in the residual plot. 
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Move to page 1.4. 
 
On page 1.4, graph the same scatter plot that you graphed on 
page 1.3.  
 
A linear least squares fitting technique can be used to model data 
that has a linear trend. Graph the least squares regression line by 
selecting Menu > Analyze > Regression > Show Linear (mx + b). 
 
 
 
 
 
 
 

 
 

 
 
 

5. Select Menu > Analyze > Residuals > Show Residual Plot 
to display the residual plot for the regression line. 
a.  Describe the residual plot for the regression line. 

 
Sample Answer: The residual plot has no pattern. 

 
 

 
Teacher Tip: Be sure that students do not assume that the residual plot 
will never have a pattern when they use the least squares regression 
equation to model the data. You might want to follow this activity up with an 
activity where a quadratic or exponential model is an appropriate model for 
a data set. If students try to fit a linear model to the data, the residual plot 
will likely have a curved pattern. This suggests that another model might be 
a better fit. 

 
Select Menu > Analyze > Residuals > Hide Residual Plot to 
remove the residual plot. 
 
Select Menu > Analyze > Residuals > Show Residual 
Squares to display the sum of the squares of the residuals for 
the regression line. 

 

 

 

22



 Interpreting Linear Models  TEACHER NOTES 
TI PROFESSIONAL DEVELOPMENT 

 

©2014 Texas Instruments Incorporated 9 education.ti.com 

b. The least squares linear regression line is the line that minimizes the sum of the squares of 
the residuals. Given your previous exploration of movable lines and residual squares, does 
this statement seem to be true? Explain your answer. 

 
Sample Answer: Yes. The sum of the squares of the residuals for my movable lines was 
always larger than the sum of the squares of the residuals for the least squares regression 
line, 2065.48 square units. 

 
c. Interpret the slope of the least squares regression equation in terms of the mean pulse 

rates. How does your answer compare to your answer to Question 1b? 
 

Sample Answer: Answers will vary depending on the slope of the students’ movable lines. 
The slope of the least squares regression equation is approximately 0.68. If the before-
exercise mean pulse rate increased by 10 beats per minute, the after-exercise mean pulse 
rate would increase by about 7 beats per minute. This increase in the after-exercise mean 
pulse rate is less than that predicted in the sample answer for Question 1b. 

 
d. According to some experts, the maximum pulse rate is 220 minus your age, and a healthy 

pulse rate during, or just after, exercise should be about 60-80% of this number. Assume 
that a 16 year-old student has a before-exercise mean pulse rate of 68 beats per minute. 
How does the after-exercise mean pulse rate predicted by the regression equation 
compare to the after-exercise pulse rate range described by the experts? 

 
Sample Answer: The least squares regression equation predicts an after-exercise mean 
pulse rate of approximately 136 beats per minute for this student. 220 – 16 = 204. 60% of 
204 is approximately 122 and 80% of 204 is approximately 163. The after-exercise beats 
per minute predicted by the regression equation (136) falls in this range (122 to 163). 

 
Note: To use the regression equation to predict an after-exercise mean pulse rate, press / 

~, and select Add Calculator to add a Calculator page. Press h and select 

stat.regeqn. In the parentheses, enter a value for the before-exercise mean pulse rate, 
and press ·. 

 

TI-Nspire Navigator Opportunity: Quick Poll 
See Note 2 at the end of this lesson. 
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Wrap Up 
Upon completion of the lesson, the teacher should ensure that students understand: 

• What a residual is, how it is represented on a graph, and what information is provided by the sum 
of squares of residuals and the residual plot. 

• If the plot of the residuals has a pattern, the model is not a good fit for the data. 
 

 
TI-Nspire Navigator 
Note 1 
Class Capture and Live Presenter 
Use Class Capture and Live Presenter while students are working on Questions 1 - 4 to display students’ 
movable lines, sum of squares, and residual plots. 
 
Note 2 
Quick Poll 
Quick Polls can be used throughout the lesson for formative assessment. Or, send multiple Quick Polls at 
the end of the lesson to identify any misconceptions that students might have. 
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Open the TI-Nspire™ document Normal_Curve_Family.tns. 
 
Have you ever heard a distribution described as normal or 
approximately normal? In this activity, you will investigate the 
family of normal curves and discover the defining characteristics of 
all curves in the family. 

  

 
Move to page 2.1. 
 
1. The distributions of many real-world variables can be closely approximated by a normal 

distribution. The equation of a normal curve is approximately 
2

2
( )
20.4( )
x

p x e
µ

σ

σ

− −

≈ , where µ is the 

mean and σ  is the standard deviation. 
a. Describe the shape, center, and spread of the curve on page 2.1. 
 
 
b. Find p(1) when µ = 1 and σ = 1. Explain how this point relates to the graph. 
 
 
c. Use the arrows to change µ and σ . Describe the changes in the graph of the normal curve. 
 
 

2. The point at which a graph changes from concave up to concave down is called the point of 
inflection. How far is a point of inflection from the center of the graph? Explain how you know. 

 
 
 
Move to page 2.2. 
 
3. a. Two characteristics of this curve are the maximum point (center) and the distance from the 

center to the point of inflection (measure of spread). Use the arrows to change µ and σ. Describe 
how the parameters in the equation affect the maximum point and why. 
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b. Predict the center, shape, and spread of the curve if µ = 3 and σ = 2. Verify your prediction 

using the sliders. 
 
 
 
Move to page 3.1. 
 
4. Consider the dashed curve. 

a. Predict the values for µ and σ that were used to create the graph. Explain why you think 
your prediction makes sense. 

 
 
 
b. Verify the predictions by typing values into Column B of the spreadsheet. (The dotted line 

will become solid when you have the correct values.) 
 
 

 
Move to page 4.1. 
 
5. a. Describe the axis of symmetry for the curve. 

 
 
b. What happens to the axis of symmetry as µ and σ change? 
 
 

6. a. The length of the segment connecting the point of inflection and the axis of symmetry represents 
the standard deviation. Describe the changes in the graph as the standard deviation increases. 

 
 
 

b. Compare a normal curve with a mean of –2 and a standard deviation of 1 to a normal curve with 
a mean of 1 and a standard deviation of 1. 
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7. a. Calculate the area of one grid box, and then count boxes to approximate the area between 
the curve and the horizontal axis when µ = 0.6 and σ = 1.8. (Note that the horizontal scale is 
marked in 1 unit intervals and the vertical scale is marked in 0.1 unit intervals.) 

 
 
 

b. Change the value of µ. Predict the total area between the curve and the horizontal 
axis. Verify by counting the boxes. 

 
 
 

c. Set µ to 0, and change the value of σ to 0.5. Use the grid boxes to approximate the area 
between the curve and the horizontal axis. 

 
 
 
d. Change σ to a new value. Predict the area between the curve and the horizontal axis. 

Verify by counting the boxes. 
 
 
 

8. A normal curve has defining characteristics related to shape, center, spread, and area. 
What are these characteristics, and how can you recognize them in a graph? 
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Math Objectives 
• Students will identify the defining characteristics of a normal 

curve related to shape, center, spread, and area. 
• Students will recognize that normal curves form a family whose 

members share these same characteristics. 
• Students will use appropriate tools strategically (CCSS 

Mathematical Practices). 
• Students will model with mathematics (CCSS Mathematical 

Practices). 
 
Vocabulary 

• normal curve • point of inflection 
• mean • standard deviation 

 
About the Lesson 
• This lesson involves investigating the relationship of the equation 

of a normal curve to its graph. As a result, students will: 
• Identify the axis of symmetry as the line x = µ, where µ is the 

mean of the distribution represented by the normal curve, and 
the standard deviation as the horizontal distance from that 
line to the point of inflection. 

• Use a slider to change the values of two parameters, µ and σ, 
to investigate their effects on the normal curve, noting in 
particular that µ represents the location of the mean and that 
σ represents the horizontal distance from the mean to either 
point of inflection. 

• Estimate the area under a normal curve graphed on a 
coordinate grid, and investigate the area as the mean and 
standard deviation are changed. 

 

TI-Nspire™ Navigator™ System 
• Send out the Normal_Curve_Family.tns file. 
• Monitor student progress using Class Capture. 
• Use Live Presenter to spotlight student answers. 
 
Activity Materials 

• Compatible TI Technologies:  TI-Nspire™ CX Handhelds,  

 TI-Nspire™ Apps for iPad®,  TI-Nspire™ Software 

 
 
Tech Tips:  
• This activity includes class 

captures from the TI-Nspire 
CX handheld. It is also 
appropriate for use with the 
TI-Nspire family of products 
including TI-Nspire software 
and TI-Nspire App. Slight 
variations to these directions 
might be required if using 
other technologies besides 
the handheld. 

• Watch for additional Tech 
Tips throughout the activity 
for the specific technology 
you are using. 

• Access free tutorials at 
http://education.ti.com/ 
calculators/pd/US/Online-
Learning/Tutorials  

 
Lesson Files: 
Student Activity 
• Normal_Curve_Family_ 

Student.pdf 
• Normal_Curve_Family_ 

Student.doc 

TI-Nspire document  
• Normal_Curve_Family.tns 
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Discussion Points and Possible Answers 
 

 
 

Tech Tip: In this activity, students will not move the two points on the 
curve manually. To change the value of µ or σ, students should move the 
cursor to the left or right arrow displayed on the screen and press x. 

 
Teacher Tip: The initial discussion refers only to the parameters µ and σ 
and not to the characteristics of a distribution. That comes into the 
investigation at Question 7, where the curve is connected to the mean and 
standard deviation of a distribution. 

 
Move to page 2.1. 
 
1. The distributions of many real-world variables can be closely 

approximated by a normal distribution. The equation of a 

normal curve is approximately 
2

2
( )
20.4( )
x

p x e
µ

σ

σ

− −

≈ , where µ is 

the mean and σ  the standard deviation. 
a. Describe the shape, center, and spread of the curve on 

page 2.1.  
 

  

Sample Answers: The curve is mound-shaped (unimodal) and seems to be symmetric to a line 
through the center—the axis of symmetry. The axis of symmetry is x = 1. The spread seems to 
go from negative infinity to positive infinity, but the curve is bunched up, mostly between –1.5 
and 3.5 or –2 and 4. The maximum point, or height, of the curve seems to be about 0.4 at x = 1. 

 

Teacher Tip: The actual equation for the normal curve is 
2

2
( )
21( )

2

x

p x e
µ

σ

σ π

− −

= .  

If you show the equation to students, be sure they recognize that π and e are 
constants. Students might be asked to determine how the equation explains the 
behavior of the graph as x approaches infinity. They should observe that the 
number e raised to a negative power is really 1 over e to that power, so as x 
increases, the fraction becomes 1 divided by a very large number. That number 
will get closer and closer to 0, and the product of a number very close to 0 and 
0.4 will also get increasingly closer to 0. 
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b. Find p(1) when µ = 1 and σ = 1. Explain how this point relates to the graph. 
 

Answer: p(1) = 0.4, which represents the height of the curve at x = 1. The point (1, 0.4) is 
the maximum point on the curve. 
  

c. Use the arrows to change µ and σ . Describe the changes in the graph of the normal curve. 
 

Answer: The graph of the curve shifts horizontally when µ is changed. It moves to the right 
when µ increases, and moves to the left when µ decreases. When σ is changed, the height 
of the graph changes. 
 

2.  The point at which a graph changes from concave up to concave down is called the point of 
inflection. How far is a point of inflection from the center of the graph? Explain how you know. 

 
Answer: The distance from a point to a line is the perpendicular distance from the point to the 
line, which is represented by the horizontal segment in the graph. The length of the segment 
from the axis of symmetry to either point of inflection is the same as the value of σ, the standard 
deviation. Using the displayed ordered pairs, you can subtract the x-coordinates. 

 
Teacher Tip: To help students understand the points of inflection, you 
might ask them how they would construct the curve using parts of curves 
they already know. They might suggest using part of a parabola that opens 
down and part of an exponential curve. The point at which the two would 
be glued together is the point of inflection. It can also be described as the 
point at which the curve, like a bowl with sloped edges, switches from 
"spilling water" to "holding water." Stress, however, that the curves in the 
graphs of the normal curves are not really parabolas. 

 
Move to page 2.2. 
 
3. a. Two characteristics of this curve are the maximum point 

(center) and the distance from the center to the point of 
inflection (measure of spread). Use the arrows to change µ 
and σ. Describe how the parameters in the equation affect 
the maximum point and why. 
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Answer: The height of the maximum point is affected by changing σ. The curve gets 
“squeezed up” as σ gets smaller. A smaller σ means the points of inflection on either side 
of the axis of symmetry are closer to the mean. The horizontal location of the maximum 
point is affected by changing µ. 
 

b. Predict the center, shape, and spread of the curve if µ = 3 and σ = 2. Verify your prediction 
using the sliders. 

 
Answer: The center of the curve will be at x = 3 on the horizontal axis, and the axis of 
symmetry will be the line x = 3. The curve will be flatter than when the standard deviation is 
1, and the tails will still approach but not touch the x-axis. The distance from the axis of 
symmetry to either point of inflection is 2. 

 
Move to page 3.1. 
 
4. Consider the dashed curve. 

a. Predict the values for µ and σ that were used to create the 
graph. Explain why you think your prediction makes sense. 

 

Sample Answers: Students might suggest the values are about µ = –2.5 and σ = 1.5. The 
value for µ is the x-coordinate of the maximum point on the curve, and the distance from 
the value of µ to the point of inflection is the value of σ. 
 

Tech Tip: To add or modify the data in a spreadsheet cell, double-tap 
the cell. 

Tech Tip: To hide the keyboard after entering a value into the 

spreadsheet, press the keyboard down button in the lower right corner . 
 

 TI-Nspire Navigator Opportunity: Quick Poll 
See Note 1 at the end of this lesson. 

b. Verify the predictions by typing values into Column B of the spreadsheet. (The dotted line 
will become solid when you have the correct values.) 

 
Answer: µ = –2.5 and σ = 1.5 
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Move to page 4.1. 
 
5. a. Describe the axis of symmetry for the curve. 
 

Answer: The axis of symmetry is a line that divides the 
curve into two congruent parts. In this case, it is the 
vertical line that goes through x = µ. 

 
 

b. What happens to the axis of symmetry as µ and σ change? 
 

Answer: The axis of symmetry is not affected at all by a change in σ. It is determined by µ ; 
the line of symmetry is the vertical line x = µ. 
 

6. a. The length of the segment connecting the point of inflection and the axis of symmetry represents 
the standard deviation. Describe the changes in the graph as the standard deviation increases. 

 
Answer: As the standard deviation increases, the graph becomes flatter and flatter, with the 
y-coordinate of the peak decreasing proportionately with increases in the value of σ. 

 
b. Compare a normal curve with a mean of –2 and a standard deviation of 1 to a normal curve with 

a mean of 1 and a standard deviation of 1. 
 

Answer: The curves are congruent. The curve with a mean of 1 could be translated 3 units to 
the left, and it would then match the curve with a mean of –2 exactly. 
 

7. a. Calculate the area of one grid box, and then count boxes to approximate the area between 
the curve and the horizontal axis when µ = 0.6 and σ = 1.8. (Note that the horizontal scale is 
marked in 1 unit intervals and the vertical scale is marked in 0.1 unit intervals.) 

 
Answer: The area of one grid box is 0.1 by 1 or 0.1 square units. By counting and 
estimating, the number of rectangles between the curve and the horizontal axis is 
approximately 9.5, so the total area is approximately 0.95 plus the small parts under the 
tails as the x-values continue to increase or decrease, for a total area of about 1. 

 
Teacher Tip: Students might need to be reminded of the extra area that is 
not clearly visible and that accumulates as x goes to plus and minus 
infinity. A smaller grid might be a way to help them get a better estimate, 
which can be done by going to Menu > Window/Zoom > Window 
Settings and resetting the x-scale to a smaller value, e.g., 0.5 or 0.25. 
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Tech Tip: The window settings can be accessed by selecting > 
Window/Zoom > Window Settings. 

b. Change the value of µ. Predict the total area between the curve and the horizontal axis. 
Verify by counting the boxes. 

 
Answer: The value of µ will not change the area because the shifted curve will be 
congruent to the original; thus areas bounded by the curve and the horizontal axis for both 
curves will be equal. 
 

c. Set µ to 0, and change the value of σ to 0.5. Use the grid boxes to approximate the area 
between the curve and the horizontal axis. 
 
Answer: If the x-scale is not changed, each rectangle formed by the grid still has an area 
of 0.1. There are still about 9.5 rectangles that are 1 by 0.1 plus the extra area as the curve 
continues along the x-axis. The total area is approximately 1 square unit. 

 
d. Change σ to a new value. Predict the area between the curve and the horizontal axis. 

Verify by counting the boxes. 
 

Answer: The area continues to be about 1 square unit. 
 

TI-Nspire Navigator Opportunity: Quick Poll 
See Note 2 at the end of this lesson. 

 
8. A normal curve has defining characteristics related to shape, center, spread, and area. 

What are these characteristics and how can you recognize them in a graph? 
 

Answer: (i) The curve is mound-shaped (unimodal) and is symmetric to a line through the 
axis of symmetry (x = µ).  

(ii) The x-coordinate of the maximum point is the mean of the distribution. The 
vertical line through the mean is the axis of symmetry for the curve. 

(ii) The standard deviation of the distribution is the horizontal distance from the axis 
of symmetry to either point of inflection. 

(iii) The total area bounded by any normal curve and the horizontal axis is always 1 
square unit. 
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Wrap Up 
Upon completion of the discussion, the teacher should ensure that students understand: 

• A normal curve has certain defining characteristics. (These characteristics are given in the 
answer to Question 8.) 

• Normal curves form a family of curves whose members share these characteristics. 
 
 
Assessment 
Identify the following as true or false. Be prepared to explain your reasoning in each case. 

a. A normal curve can be short and flat or tall and skinny. 
 

Answer: True; a large value of σ creates a short, flat curve, and a small value of σ creates 
a tall, skinny curve. 

 
b. You can make two normal curves so that one would fit completely inside the other. 

 
Answer: False; the area between every normal curve and the x-axis is 1 square unit, so it 
is impossible to have one normal curve completely under another. 

 
c. It is possible to create a normal curve such that the area between the curve and the x-axis 

is more than 1. 
 

Answer: False; the area between every normal curve and the x-axis is 1 square unit. 
 

d. All normal curves are symmetric. 
 

Answer: True; the curves are symmetric about the line x = µ, the mean of the distribution. 
 
e. There is some value of x such that the point (x, 0) is on the normal curve. 

 
Answer: False; if this were true, the curve would touch the x-axis, but that is impossible 
given the equation of the normal curve. The y-coordinate of a point on the normal curve is 
never equal to zero. 
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TI-Nspire Navigator 

Note 1 
Question 4 part a, Quick Poll 
Use Quick Poll to gather students’ predictions for the values of µ and σ. Tip: Poll the variables one at a 
time by having them enter just the number. This will minimize the variation in the responses. 
Pick one student’s value from those submitted and discuss with students why they think it will or will not 
match the curve graphed. 
 
Note 2 
Question 7, Quick Poll 
To assess student understanding of the area under a normal curve, send one or several open response 
Quick Polls. For example, “What is the area under a normal curve with µ = 5 and σ = 2?” Students should 
always response with “1” or “approximately 1”. 
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Open the TI-Nspire™ document Empirical_Rule.tns. 
 
Does any connection exist between 1) the area under the standard 
normal curve for a given number of standard deviations from the 
mean, and 2) the area under any member of the family of normal 
curves for the same number of standard deviations from the 
mean?  

 

 

 
Move to page 2.1. 
 

Press / ¢ and / ¡ to 

navigate through the lesson. 
 
1. The graph in the top work area is called the standard normal curve. The mean is 0, and the 

standard deviation is 1. The current z-value is 1. The z-value gives the distance from the mean, 
in numbers of standard deviations, to a boundary of the shaded region. Note that due to the 
symmetry of the standard normal curve, the point at the left boundary is z = -1. 
a. Drag the point on the z-axis in the top work area, and describe what changes. 
 
 
b. Drag the point on the z-axis back to z = 1.0. What is the area of the shaded region? 
 

 
2. Consider the normal curve in the bottom work area with a mean of 0 and a standard deviation of 2. 

a. How does this graph compare to the graph in the top work area? 
 
 
b. Match the Area: Drag the point on the x-axis of the graph in the bottom work area until the 

area of the shaded region matches the area of the shaded region in the graph in the top 
work area as closely as possible. How are the x-values (the cut points) of the graph in the 
bottom work area related to the z-value when the areas are similar? Explain why this is 
reasonable. 

 
 

c. Repeat Match the Area using each z-value below. Describe how the x-values (the cut points) 
are related to the z-value when the areas are approximately the same. 
(i) z = 2 

 
(ii) z = 3 
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Move to page 3.1. 
 
3. The graph in the top work area is the standard normal curve as originally displayed in the top work 

area on Page 2.1. The graph in the bottom work area is a normal curve with a mean of 0 and 
standard deviation controlled by the slider to the left of σ. 
a. Adjust the slider so that the standard deviation in the bottom graph is 1.5, and then change the 

x-value (the cut point) to play Match the Area again. How is this x-value (cut point) related to 
the z-value shown in the top graph? 

 
 

b. With σ equal to 1.5 in the bottom graph, repeat Match the Area using each z-value below. 
Compare your answers to those you found in Question 2, part c. 
(i) z = 2 

 
(ii) z = 3 

 
 

4. Repeat Match the Area with several more choices for σ. Summarize your conclusions about the 
relationship between the area of the shaded region in the bottom work area and standard 
deviations. 

 
 
 
5. Suppose that the mean of a normal curve is µ = 2.5 and that the standard deviation is σ = 1.5.  

What are the cut points of the region whose area is approximately 95% of the area under the curve? 
 
 

Summary: The area, when the cut points of the shaded region are 1 standard deviation from the 
mean for any member of the family of normal curves, is approximately 0.683 square units; the area, 
when the cut points of the shaded region are 2 standard deviations from the mean, is approximately 
0.954 square units; and the area, when the cut points of the shaded region are 3 standard 
deviations from the mean, is approximately 0.997 square units. These three areas are 
approximately 68%, 95%, and 99.7%, respectively, of the total area under any normal curve  
(1 square unit). These area percentages are often referred to as the “68 – 95 – 99.7 rule” or the 
Empirical Rule. 
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Move to page 4.1. 
 
The heights in centimeters of all of the students in a school have 
been entered into the spreadsheet. 

 

 
Move to page 4.2. 
 
6. Create a dot plot on this page following these steps: 

• Move the cursor to the bottom work area, and click on “Click to Add Variable.” 
• Select the variable heights_cm. A dot plot will be graphed. 

 a. How would you describe the dot plot? 
 
 

 
 Select Menu > Plot Type > Histogram.  

b. For the histogram displayed, would you describe the graph in the same way that you 
described the dot plot? Why or why not? 

 
 

 
Move to page 4.3. 
 
Page 4.3 is a Calculator page. Select Menu > Statistics > Stat Calculations > One-Variable 
Statistics. The current number of lists (Num of Lists) shown in the first dialog box is 1. Click OK. In 
the second dialog box, click in the region to the right of X1 List, and select heights_cm. Click OK.  
 
7. What is the mean height ( )x of the students in the school? Round your answer to the nearest 

tenth. 
 
 
8. What is the standard deviation (σx) of the heights of the students in the school? Round your 

answer to the nearest tenth. 
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9. Since the graph of the heights of the students in the school is unimodal and approximately 
symmetric, we can make generalizations about the heights of students at the school based on 
your explorations of normal curves. Use your rounded values from Questions 7 and 8 to 
compute your answers. 

 a. Find the values of the left and right cut points that are 1 standard deviation from the mean.  
 
 
 

b. What is the range of the heights of the students who represent the central 68% of the 
population? 

 
 
 

c. What is the range of the heights of the students who represent the central 95% of the 
population? 

 
 
 

d. What are the heights of the students in the top 2.5% of the population? 
 
 
 

e. A height that is more than 3 standard deviations from the mean is considered to be unusual. 
Are there any students in this population whose heights are unusual? 
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Math Objectives 
• Students will associate the area bounded by a normal curve, 

the horizontal axis, and a vertical cut point with probability. 
• Students will recognize that for any member of the family of 

normal curves, the percent of area bounded by the normal curve, 
the horizontal axis, and z = 1, 2, and 3 standard deviations are 
the same. 

• Students will recognize the Empirical Rule can be used to make 
generalizations about the population given a histogram of values 
that can be approximated by a normal curve. 

• Students will reason abstractly and quantitatively (CCSS 
Mathematical Practices).  

Vocabulary 
• standard normal curve  • mean 
• standard deviation  

About the Lesson 
• This lesson involves finding the area bounded by the standard 

normal curve and the horizontal axis for a given number of 
standard deviations from the mean and comparing this area to 

the corresponding area for another member of the family of 
normal curves. 

• As a result, students will: 

• Play a Match the Area game, and learn that the areas of 
the regions that are 1, 2, and 3 standard deviations from 
the mean are approximately 68%, 95%, and 99.7%, 

respectively, of the total area under the curve regardless 
of which normal curve is being examined.  

• Change the standard deviation to learn that the area 

between the cut points determined by any given distance 
from the mean, when measured in standard deviation units, 
is the same for any member of the family of normal curves. 

• Apply the Empirical Rule to answer questions about a data 
set for a population. 

TI-Nspire™ Navigator™ 
• Use Class Capture to examine the values of x (cut points) that 

match the area under the curve of the graph in the bottom work 
area to the graph in the top work area. 

• Use Quick Poll questions to adjust the pace of the lesson 
according to student understanding. 

 
 

TI-Nspire™ Technology Skills:  
• Download a TI-Nspire 

document 

• Open a document 
• Move between pages 
• Grab and drag a point 
 
Lesson Files: 
Student Activity 
• Empirical_Rule_Student.pdf 

TI-Nspire document  
• Empirical_Rule.tns 
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Discussion Points and Possible Answers 
 

Tech Tip: If students experience difficulty dragging a point, make sure that 
they have moved the cursor (arrow) until it becomes a hand (÷) getting 

ready to grab the point. Then press / x to grab the point and close the 
hand ({). When finished moving the point, press d to release the point. 

Teacher Tip: The family of normal curves is defined by the function: 

. Each different value of  and  determines a 

different function in this family.  

 

Move to page 2.1. 
 
1. The graph in the top work area is called the standard normal 

curve. The mean is 0 and the standard deviation is 1. The 
current z-value is 1. The z-value gives the distance from the 
mean, in numbers of standard deviations, to a boundary of the 

shaded region. Note that due to the symmetry of the standard 
normal curve, the point at the left boundary is z = -1. 

 

 

Teacher Tip: The standard normal curve is defined as a normal curve with 
a mean of zero and a standard deviation of one. Varying the mean or the 
standard deviation produces a different member of the family of normal 

curves. 

a. Drag the point on the z-axis in the top work area, and describe what changes. 
 

Sample Answer: The shaded region changes and the area changes, increasing as the 
point is dragged to the right and decreasing as the point is dragged to the left. 

 

b. Drag the point on the z-axis back to z = 1.0. What is the area of the shaded region? 
 

Answer: Approximately 0.683 square units 

Teacher Tip: Be sure students recognize that the areas are all 

approximate and are accurate only to three decimal places. As the point on 
the z-axis is moved to the far right, the value for the area might appear as 1 
square unit. This value is rounded. The total area under the normal curve 

bounded by the horizontal axis is 1 square unit. The area value given as 
the answer to Question 1b (0.683 square units) is 68.3% of the total area.  
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2.  Consider the normal curve in the bottom work area with mean 0 and standard deviation 2. 
a. How does this graph compare to the graph in the top work area? 

 
Sample Answer: This is the graph of a normal curve having mean 0 and standard 
deviation 2. The region under the curve bounded by the horizontal axis and between x = -1 

and x = 1 has been shaded. Students might also note that the areas are different. 
 
b. Match the Area: Drag the point on the x-axis of the graph in the bottom work area until the 

area of the shaded region matches the area of the shaded region in the graph in the top 
work area as closely as possible. How are the x-values (the cut points) of the graph in the 
bottom work area related to the z-value when the areas are similar? Explain why this is 

reasonable. 
 

Sample Answer: The areas (0.683 square units) match when the cut points are at x = -2 and 

x = 2. The distance from the mean to either x-value is one standard deviation for this normal 
curve. The location of the z-value for the standard normal curve is also one standard deviation 
from the mean. The standard deviation of the graph in the bottom work area is twice the 

standard deviation of the standard normal curve and the x-value of 2 is twice the z-value. The 
graph in the bottom work area is flatter and more spread out, so it makes sense that you 
would have to move further along the x-axis in the bottom graph to have the same area under 

each curve. 
 
Teacher Tip: In order to move from the top work area to the bottom work 
area (or vice versa), click in the desired work area or press / e.  

 
c. Repeat Match the Area using each z-value below. Describe how the x-values (the cut 

points) are related to the z-value when the areas are approximately the same. 

Teacher Tip: Be sure students remember the steps for Match the Area.  
Drag the point on the x-axis until the area in the bottom graph matches the 
area in the upper graph as closely as possible. 

 
 (i) z = 2 

 

Sample Answer: When z = 2 in the standard normal curve, the corresponding x-value 
that results in the same area, 0.954 square units, in the bottom graph is 4. The distance to 
either cut point (-4 or 4) is twice the standard deviation of the normal curve in the bottom 

work area. The distance of the z-value from the mean is twice the standard deviation of 
the standard normal curve. 
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(ii) z = 3 
 

Sample Answer: When z =3 in the standard normal curve, the corresponding x-value that 
results in the same area, 0.997 square units, in the bottom work area graph is 6. The 

distance to either cut point (-6 or 6) is three times the standard deviation of the normal 
curve in the bottom graph. The distance of the z-value from the mean is three times the 
standard deviation of the standard normal curve. 

 

TI-Nspire Navigator Opportunity: Class Capture 
See Note 1 at the end of this lesson. 

 
Move to page 3.1. 
 

3. The graph in the top work area is the standard normal curve as 
originally displayed in the top work area of Page 2.1. The 
graph in the bottom work area is a normal curve with a mean 

of 0 and a standard deviation controlled by the slider to the left 
of σ.  
a. Adjust the slider so that the standard deviation in the 

bottom graph is 1.5, and then change the x-value to play 
Match the Area again. How is this x-value (cut point) 
related to the z-value shown in the upper graph? 

 

 

 

Sample Answer: The areas (0.683 square units) match when the x-value is 1.5. The 
distance to either cut point (-1.5 or 1.5) from the mean is one standard deviation. The  

z-value in the graph in the top work area is also one standard deviation from the mean. 
 
b. With σ equal to 1.5 in the bottom graph, repeat Match the Area using each z-value below. 

Compare your answers to those you found in Question 2 part c.  
(i) z = 2 

 

Sample Answer: When z = 2 in the standard normal curve, the corresponding x-value that 
results in the same area, 0.954 square units, in the bottom graph is 3. The distance to 
either cut point (-3 or 3) from the mean is twice the standard deviation of the normal curve 

in the bottom graph. The distance of the z-value from the mean is twice the standard 
deviation of the standard normal curve. 
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(ii) z = 3 

 
 Sample Answer: When z = 3 in the standard normal curve, the corresponding x-value that 

results in the same area, 0.997 square units, in the bottom graph is 4.5. The distance to either 
cut point (-4.5 or 4.5) from the mean is three times the standard deviation of the normal curve in 
the bottom graph. The distance of the z-value from the mean is three times the standard 

deviation of the standard normal curve. 
 

Teacher Tip: At this stage, students should recognize the fact that the cut 

point at the boundary of the shaded region is the product of the standard 
deviation and the number of standard deviations from the mean.  

 

TI-Nspire Navigator Opportunity: Quick Poll 
See Note 2 at the end of this lesson. 

 
4. Repeat Match the Area with several more choices for σ. Summarize your conclusions about the 

relationship between the area of the shaded region in the bottom work area and standard deviations. 
 

Sample Answer: The area, when the cut points of the shaded region are 1 standard deviation 

from the mean for any member of the family of normal curves, is approximately 0.683 square 
units; the area, when the cut points of the shaded region are 2 standard deviations from the 
mean, is approximately 0.954 square units; and the area, when the cut points of the shaded 

region are 3 standard deviations from the mean, is approximately 0.997 square units. 
 
5. Suppose that the mean of a normal curve is µ = 2.5 and that the standard deviation is σ = 1.5.   

What are the cut points of the region whose area is approximately 95% of the area under the curve? 
 

Answer:  The left cut point would be -0.5 ( 2.5 – (1.5)(2) = -0.5), and the right cut point would be  

5.5 (2.5 + (1.5)(2) = 5.5). 
 
Summary: The area, when the cut points of the shaded region are 1 standard deviation from 

the mean for any member of the family of normal curves, is approximately 0.683 square units; 
the area, when the cut points of the shaded region are 2 standard deviations from the mean, is 
approximately 0.954 square units; and the area, when the cut points of the shaded region are 3 

standard deviations from the mean, is approximately 0.997 square units. These three areas are 
approximately 68%, 95%, and 99.7%, respectively, of the total area under any normal curve  
(1 square unit). These area percentages are often referred to as the “68 – 95 – 99.7 rule” or the 

Empirical Rule.  
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Move to page 4.1. 
 
The heights in centimeters of all of the students in a school have 
been entered into the spreadsheet. 

  
 
 

 

 

Move to page 4.2. 
 

6. Create a dot plot on this page following these steps: 
• Move the cursor to the bottom part of the screen, and click 

on “Click to Add Variable.” 

• Select the variable heights_cm. A dot plot will be graphed. 
a. How would you describe the dot plot? 
 

Sample Answer: The plot appears unimodal and fairly 
symmetric.  

 

Select Menu > Plot Type > Histogram.   
b. For the histogram displayed, would you describe the 

graph in the same way that you described the dot plot? 

Why or why not? 
 

Sample Answer: Yes. The histogram also appears to be 

unimodal and fairly symmetric. 
 

 
 

 
  

 
 
 

 

Teacher Tip: For data whose graphical representation appears to be 
unimodal and fairly symmetric, a normal curve provides a good fit for the 

graph of the data and the mean and standard deviation are the accepted 
measures of center and spread. For data that are skewed, the median and 
the IQR (Interquartile range) are the accepted measures of center and 

spread. 
 

46



 Empirical Rule  TEACHER NOTES 
TI PROFESSIONAL DEVELOPMENT 

 

©2014 Texas Instruments Incorporated 7 education.ti.com 

Move to page 4.3. 
 
Page 4.3 is a Calculator page. Select Menu > Statistics > Stat 
Calculations > One-Variable Statistics. The current number of 

lists (Num of Lists) shown in the first dialog box is 1. Click OK. In 
the second dialog box, click in the region to the right of X1 List 
and select heights_cm. Click OK.   

 
7.   What is the mean height ( )x  of the students in the school? 

Round your answer to the nearest tenth. 
 

Answer: Mean = 152.9 cm 

 
 
 

 
 

 

8. What is the standard deviation (σx) of the heights of the students in the school? Round your 
answer to the nearest tenth. 

 

Answer: Standard deviation = 13.2 cm 
 

Teacher Tip: We use the Population Standard Deviation, σx, since the 

data in the spreadsheet are the heights of all of the students in the school 
(the population). 

 
9. Since the graph of the heights of the students in the school is unimodal and approximately 

symmetric, you can make generalizations about the heights of students at the school based on 
your explorations of normal curves. Use your rounded values from Questions 7 and 8 to 

compute your answers. 
 a. Find the values of the left and right cut points that are 1 standard deviation from the mean.  
 

Answer: Left cut point = 139.7 cm; Right cut point = 166.1 cm 
 

b. What is the range of the heights of the students who represent the central 68% of the 

population? 
 

Answer: 139.7 cm to 166.1 cm  

 
c. What is the range of the heights of the students who represent the central 95% of the 

population? 
 

Answer:  126.5 cm to 179.3 cm 
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d. What are the heights of the students in the top 2.5% of the population? 
 

Answer: Heights that are more than 179.3 cm 
 

 
e. A height that is more than 3 standard deviations from the mean is considered to be unusual.  

Are there any students in this population whose heights are unusual? 
 

Answer:  A student height that is less than 113.3 cm or more than 192.5 cm would be 
unusual. There are no students in this school with a height that is unusual because the 

minimum student height is 118 cm and the maximum student height is 185 cm.  
 

 

 

Wrap Up 
Upon completion of the discussion, the teacher should ensure that students are able to understand: 

• The Empirical Rule as it relates to areas bounded by the graph of a normal curve and the 
horizontal axis. 

• That regions under normal curves will always have the same area if their cut points are the 
same number of standard deviations from their means. 

 
 
TI-Nspire™ Navigator™ 
Note 1 
Question 2, Class Capture 
Use Class Capture to determine if all students found the correct x-values in Question 2c. 
 

Note 2 
Question 3, Quick Poll 
Use Open Response Quick Polls to check students’ responses for the x-values (cut points).  
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Open the TI-Nspire™ document Sampling_Distributions.tns. 
 
What is a sampling distribution of a statistic? A sampling 
distribution is the distribution of values of a given statistic based 
on all possible samples of a given size from a given population. In 
this activity, you will explore and describe the sampling distribution 
of the sample mean by creating and observing the means of a 
number of different samples from a given population. 

 

 
 

 
Move to page 1.2. 
 

Press / ¢ and / ¡ to 

navigate through the lesson. 
This activity involves generating a number of random samples from a population. In order to avoid having 
your results be identical to those of another student in the room, it is necessary to “seed” the random 
number generator. Read the instructions on page 1.2 for seeding your random number generator. 
 
Move to page 2.1. 
 
1. The graph on this page shows a normal distribution with mean 0 and standard deviation 1, 

representing a population of values. Recall the empirical rule and your knowledge of normal 
distributions. Predict the shape, center, and spread of a sample randomly selected from this 
population. 

 
 
2. Each time you click the arrow (▲) labeled draw, you generate a random sample of size 10 from 

the given population. The elements of the sample will be displayed as points on the x-axis. 
Click to select the first sample. Look particularly at the center and spread of the values selected 
in the sample. Even though you have selected only 10 values from the population, do they 
seem to support your predictions in Question 1? Explain. 

 
 
3. In addition to the 10 values that make up the sample, a vertical line is displayed on the plot. 

What do you think it represents? Explain your reasoning. 
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4. Think about the variability among the values that make up your sample and the variability 
among the vertical x  lines for several different samples. 
a. Use draw to select another sample (still of size 10). Record the value of x , and write a short 

description of how the individual values of your sample are distributed (look back at Question 2). 
 
 

b. Repeat part a four more times. Describe how the values of x vary compared to how the 
individual values in the samples vary. 

 
 

c. Predict the center, spread, and shape of the distribution that would be formed by all x  values 
from a large number of samples. Explain. 

 
 
 
Move to page 3.1. 
 
5. The top work area on Page 3.1 shows the same population from Questions 1–4. An axis for a 

new dot plot has been added in the lower work area. 
a. Click draw five times, and describe what seems to be happening in the dot plot. 

 
 

b. What variable do you think is being plotted in the dot plot? 
 
 
6. Click draw five more times to generate more values in the dot plot. Does the dot plot seem to 

confirm the predictions you made in Question 4 about the center, spread, and shape of the 
distributions of the x  values from a large number of samples? Explain. 

 
 
7. You know several measures of spread. Think of one of those measures.  

a. Without doing any actual calculations, estimate the value of that measure of spread, first for 
the set of individual values in the samples themselves, and then for the set of values in the 
dot plot in the lower screen on Page 3.1. 

 
 
 

b. How do the measures of spread for the individual values and the sample means compare? 
Explain any differences you see. 
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Move to page 3.2. 
 
8. The top work area on Page 3.2 is an exact copy of the lower work area on Page 3.1 with which 

you have been working. The lower work area displays the same data ( x  values from your 
samples) in a histogram. 
a. Comment on which display seems better for seeing the overall shape of the distribution. 

Explain your reasoning. 
 
 
 

Move back to page 3.1. 
 

b. Each click of the draw arrow will generate ten more samples, and the means of those 
samples will be added to the plot in the lower work area. Click draw until you have about 
100 samples, and then look at the graphs on page 3.2. Which graph type seems most 
appropriate for this larger simulation? Explain. 

 
 
c. Describe the shape of the distribution of sample means. Estimate the mean and standard 

deviation of this distribution. 
 

 
Move to page 3.3. 
 
The plot on Page 3.3 is an exact copy of the histogram you examined on Page 3.2 but has an 
“adjustable” normal curve in the window. You can control the appearance of that curve by clicking 
on the arrows (▲ or ▼) to select a mean and standard deviation. 
9. Use the arrows (▲ or ▼) to set the mean and standard deviation to match the estimates you 

made in Question 8c. Then, if necessary, re-adjust the values so that they fit your histogram as 
well as possible. Record your final values for mean and standard deviation. Comment on the 
accuracy of your predictions. 
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Move to page 4.1. 
 
All of the students in grades 9-12 at a school measured the circumferences of their heads. The 
draw arrow will select different samples of size ten from the school population, and the mean 
circumference of the students' heads will be displayed in the lower plot.  
10. a Use pages 4.1 and 4.2 to repeat the “sample-size-10” explorations you carried out in 

Questions 8 and 9 with this new population. Describe the sampling distribution of mean head 
circumferences for samples of size 10 taken from all grades 9-12 students in the school. 
 
 

Note: Click the reset arrow on page 4.1 to erase an exploration using one sample size in order to 
begin a new exploration with another sample size. 
 

b. The lower and upper arrows will generate samples of sizes other than 10 by changing the 
value of n. Repeat these explorations once more, this time using a different sample size. 
Comment on how changing the sample size affects the center, spread, and shape of the 
distribution of mean head circumference. Be as specific as possible, indicating what happens 
when the sample size increases and what happens when the sample size decreases. 

 
 
 
11. Write a brief description to explain what you learned about a sampling distribution of sample 

means for someone who did not do this activity. 
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Math Objectives 
• Students will recognize that the means of different samples from a 

normal population will vary symmetrically around the mean of the 
population, with values near the mean occurring more frequently 
than those further from the mean, but in a narrower interval than 
that of individual elements of the population. 

• Students will recognize that as sample size increases, variability 
(spread) in the sampling distribution of sample means decreases. 

• Students will look for and make use of structure (CCSS 
Mathematical Practices). 

• Students will model with mathematics (CCSS Mathematical 
Practices). 

 
Vocabulary 
• dot plot • sample 
• histogram • sample mean 
• mean • sampling distribution 
• normal distribution • standard deviation 
• population  

 
About the Lesson 
Note that this lesson is not about establishing the central limit 
theorem but rather is focused on helping students understand what a 
sampling distribution is. This would be a good activity prior to 
introducing the central limit theorem. 
• This lesson involves examining samples from a normal population 

and observing the distribution of the means of those samples. 
• As a result, students will: 
• Understand that the sample mean varies from sample to sample, 

having its own distribution. 
• Estimate descriptive measures for the sampling distribution, and 

use those measures to approximate the simulated sampling 
distribution by selecting the mean and standard deviation for 
overlaying a normal curve. 

 
TI-Nspire™ Navigator™ System 
• Send the TI-Nspire document to students. 
• Use Class Capture to display multiple distributions. 
• Use Quick Poll to compare student sample means. 

 
 
TI-Nspire™ Technology Skills: 
• Download a TI-Nspire 

document 
• Open a document 
• Move between pages 
• Operate a minimized slider 
 
Tech Tips: 
• Make sure the font size on 

your TI-Nspire handhelds is 
set to Medium. 

 
Lesson Files: 
Student Activity 
Sampling_Distributions 
_Student.pdf 
Sampling_Distributions 
_Student.doc 

TI-Nspire document  
Sampling_Distributions.tns 
 
Visit www.mathnspired.com for 
lesson updates and tech tip 
videos. 
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Prerequisite knowledge 
• Normal distributions and the empirical rule 
• Random samples 
• Descriptive measures (mean and standard 

deviation) 

Prerequisite Activities 
• Normal Curve Family 
• Z-Scores 
 

 
Discussion Points and Possible Answers 
 

 
 

Tech Tip: Page 1.2 gives instructions on how to seed the random number 
generator on the TI-Nspire. Page 1.3 is a Calculator page for the seeding 
process. Ensuring that students carry out this step will prevent students 
from generating identical data. (Syntax: RandSeed #, where # is a number 
unique to each student.) To complete the command, press ·. 

 
Teacher Tip: The main goal of Questions 1–5 is to have students realize 
that the sample mean is itself a variable that has a distribution whose 
shape, center, and spread can be described in its own right. 

By thinking about the averaging process, students should conclude that the 
set of means should have a center near the population mean but should be 
less variable than the values that make up the population. It is easier to get 
a single value from the population that is, say, above x = 2 than it is to get 
10 separate values whose mean is above x = 2. 

The remainder of the lesson provides simulation experiences aimed at 
quantifying these properties, at least approximately. 

 
 

Tech Tip: Page 2.1 initially shows only a normal density curve and 
minimized slider labeled “draw.” Instruct students to use only the “up” arrow 
on the slider as they proceed through this lesson. 

 
Move to page 2.1. 
 
1. The graph on this page shows a normal distribution with   

mean 0 and standard deviation 1, representing a population of 
values. Recall the empirical rule and your knowledge of normal 
distributions. Predict the shape, center and spread of a sample 
randomly selected from this population. 

 

 

Sample Answers: Sample values will bounce around, with some above 0 and some below 0. 
There will be no real pattern, but values very near 3 or –3 will be rare. 
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Teacher Tip: The elements that make up the sample come from the 
population. Thus, the population’s characteristics should be reflected in the 
distribution of those sample elements. The values of individual elements in 
samples should fall approximately symmetrically around 0, with a mean 
near 0. It will be rare to find values as large as 3 or as small as –3, but 
values as extreme as –2 or 2 should occur occasionally. Discuss these 
ideas after students have completed Question 2. 

 
2. Each time you click the arrow (▲) labeled draw, you generate a random sample of size 10 from 

the given population. The elements of the sample will be displayed as points on the x-axis. 
Click to select the first sample. Look particularly at the center and spread of the values selected 
in the sample. Even though you have selected only 10 values from the population, do they 
seem to support your predictions in Question 1? Explain. 

 
Sample Answers: For most students, the answer will be yes, at least somewhat. For example: The 
values are not quite symmetrical around 0, but the prediction about not often getting close to 3 or –3 
was right. The high value appears to be around 1.7, and the low is about –1.9, with four values below 
the mean and six above it. That all seems reasonable and matches the prediction pretty well. 
 

3. In addition to the 10 values that make up the sample, a vertical line is displayed on the plot. 
What do you think it represents? Explain your reasoning. 

 
Sample Answers: It is labeled  and appears to be around the middle of the sample, so it 
represents the mean of the sample. If you estimated the mean of the distribution or the “balance 
point,” it would be about where  falls. 
 

Teacher Tip: Be sure students recognize that the plotted line is the mean 
and not the median. It might be worthwhile to have students verify that the 
line is not exactly midway between the fifth and sixth dots in the sample. 

 
Teacher Tip: To help students begin to see the variability among values of 

, you might want to have the class share their graphs and/or values of  
with each other after completing Question 3. 

 

TI-Nspire Navigator Opportunity: Class Capture 
See Note 1 at the end of the lesson. 
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4. Think about the variability among the values that make up your sample and the variability 
among the vertical  lines for several different samples. 
a. Use draw to select another sample (still of size 10). Record the value of , and write a short 

description of how the individual values of your sample are distributed (look back at Question 2). 
 

Sample Answers: The values are somewhat similar to those in Question 2 but not exactly 
the same. They still bounce around 0 and stay away from 3 or –3. The high and low values 
changed.  is 0.262. 

 
b. Repeat part a four more times. Describe how the values of  vary compared to how the 

individual values in the samples vary. 
 

Sample Answers: The individual values remain similar to those in Question 2 but not 
exactly the same. They still bounce around 0 and, for the most part, still stay away from 3 
or –3. The high and low values change for each sample.  seems to vary a lot less than 
the individual values in the sample. Some  values fall above 0, and some fall below 0, but 
none are anywhere near the high and low values for the individual values. 
 

c. Predict the center, spread, and shape of the distribution that would be formed by the  values 
from a large number of samples. Explain. 

 
Sample Answers: The  values should fall roughly symmetrically around 0. The mean of 
a sample of size 10 will fall somewhere in the “middle” of the 10 values that make up the 
sample itself, so  should not be very far from 0. Getting a really large mean would require 
that all 10 individual values were really large, and, based on the answers to parts a and b, 
that does not seem likely. 
 

Move to page 3.1. 
 
5. The top work area on page 3.1 shows the same population 

from Questions 1–4. An axis for a new dot plot has been 
added in the lower work area. 
a. Click draw five times, and describe what seems to be 

happening in the dot plot. 
 

Sample Answers: Each click produces a new value 
plotted in the dot plot directly below the value of  in 
the sample in the upper screen. 
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b. What variable do you think is being plotted in the dot plot? 
 

Sample Answers: The variable is , the sample mean. 
 

6. Click draw five more times to generate more values in the dot plot. Does the dot plot seem to 
confirm the predictions you made in Question 4 about the center, spread, and shape of the 
distributions of the  values from a large number of samples? Explain. 

 
Sample Answers: Yes. The values are accumulating on either side of 0, roughly 
symmetrically. It looks as though the center of this set of values might be 0, and the spread is 
noticeably smaller than that of any of the individual samples themselves. 
 

7. You know several measures of spread. Think of one of those measures. 
a. Without doing any actual calculations, estimate the value of that measure of spread, first for 

the set of individual values in the samples themselves, and then for the set of values in the 
dot plot in the lower screen on Page 3.1. 

 
Sample Answers: IQR (interquartile range) describes the spread of the middle half of the 
values being examined. An estimate of the IQR for the individual values in the samples is 
about 2. For the dot plot of , the IQR seems to be less than 1, maybe 0.5. 

 
b. How do the measures of spread for the individual elements and the sample means compare? 

Explain any differences you see. 
 

Sample Answers: The IQR for sample means is definitely less than the IQR for the 
individual elements in the samples. Since the sample means are always “in the middle of 
the sample,” they do not bounce around as much as the individual values in the sample. 
 

Teacher Tip: Be sure students understand that the mean of the sample, , 
represents a measure of the center, and high and low individual values 
have been “averaged out” toward that center. This decrease in variability is 
very visible in comparing the distribution of sample means with the 
population distribution. The extremes in the tails of the population visible in 
the top screen on Page 3.1 that would occur in a sample have been 
averaged with the other values in the sample, and consequently, the 
spread is smaller for the distribution of sample means displayed in the 
lower screen on Page 3.1. 
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Move to page 3.2. 
 
8. The top work area of Page 3.2 is an exact copy of the lower 

work area on Page 3.1 with which you have been working. The 
lower work area displays the same data (  values from your 
samples) in a histogram.  
 
 

 

Teacher Tip: When a histogram is graphed, the y-axis scale can be set to 
Frequency, Percent, or Density. When the scale on the vertical axis is 
density, the histogram has been scaled so that the total area of the 
histogram is 1 square unit. 

 
Tech Tip: Depending upon the sample size and number of draws, the 
vertical axis on page 4.2 may need to be adjusted to display all of the 
histogram. Grab and drag a tic mark on the vertical axis to adjust, as 
needed. 

a. Comment on which display seems better for seeing the overall shape of the distribution. 
Explain your reasoning. 
 
Sample Answers: Answers will vary. The dot plot may appear better if the histogram’s 
bars are separated and/or short.  

 
Move back to page 3.1. 

b. Each click of the draw arrow will generate ten more samples, and the means of those 
samples will be added to the plot in the lower work area. Click draw until you have about 
100 samples, and then look at the graphs on page 3.2. Which graph type seems most 
appropriate for this larger simulation? Explain. 

 
Sample Answers: Answers may vary, but the histogram is likely the better display of the overall 
shape of the distribution. The histogram appears less cluttered than the 100-point dot plot. 

 
c. Describe the shape of the distribution of sample means. Estimate the mean and standard 

deviation of this distribution. 
 

Sample Answers: It appears symmetric and mound-shaped, approximately normally 
distributed. The mean is approximately 0. The standard deviation might be 0.5. 
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Teacher Tip: While it is not a major point of the lesson, students should 
become aware that histograms tend to be better representations of data 
when there are more data present, since histograms display values in a 
“grouped” manner. Dot plots involve no grouping, so they do better where 
there are few data. 

 

TI-Nspire Navigator Opportunity: Class Capture and Quick Poll 
See Notes 2 and 3 at the end of the lesson. 

 
Move to page 3.3. 
 
The plot on Page 3.3 is an exact copy of the histogram you 
examined on Page 3.2 but has an “adjustable” normal curve in the 
window. You control the appearance of that curve by clicking on 
the arrows (▲ or ▼) to select a mean and standard deviation. 

  

9. Use the arrows (▲ or ▼) to set the mean and standard deviation to match the estimates you 
made in Question 8c. Then, if necessary, re-adjust the values so that they fit your histogram as 
well as possible. Record your final values for mean and standard deviation. Comment on the 
accuracy of your predictions. 
 
Sample Answers: The mean was close, but the standard deviation is even smaller than my 
guess. The actual standard deviation value is more like 0.3. 

 
Move to page 4.1. 

 

Teacher Tip: The sample size should not be changed once the student 
starts to draw samples in a particular exploration. 

 
All of the students in grades 9-12 at a school measured the circumferences of their heads. The 
draw arrow will select different samples of size ten from the school population, and the mean 
circumference of the students' heads will be displayed in the lower plot.  
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10. a Use pages 4.1 and 4.2 to repeat the “sample-size-10” explorations you carried out in 
Questions 8 and 9 with this new population. Describe the sampling distribution of mean head 
circumferences for samples of size 10 taken from all grades 9-12 students in the school. 

 
Sample Answers: The means of the head circumferences for 10 students appear to be 
around 55 and are more concentrated than the distribution of individual head sizes of the 
high school students (smaller standard deviation, around 0.2 or 0.3). The shape appears 
roughly symmetric and mound-shaped. 

 
Note: Click the reset arrow on page 4.1 to erase an exploration using one sample size in order to 
begin a new exploration with another sample size.   
 

b. The lower and upper arrows will generate samples of sizes other than 10 by changing the 
value of n. Repeat these explorations once more, this time using a different sample size. 
Comment on how changing the sample size affects the center, spread, and shape of the 
distribution of mean head circumference. Be as specific as possible, indicating what happens 
when the sample size increases and what happens when the sample size decreases. 

 
Sample Answers: The overall results are the same, with the exception of spread. Larger 
samples lead to smaller spreads in the sampling distribution of mean head circumference. 
Smaller samples let the mean head size vary more. 

 
11. Write a brief description to explain what you learned about a sampling distribution of sample 

means for someone who did not do this activity. 
 
Sample Answers: Student responses should mention that when a random sample is drawn from a 
population, its sample mean can be calculated. Repeated samplings give a set of sample means that 
can be plotted to make a simulated sampling distribution. This distribution will have about the same 
mean as the original population and will be symmetric around that mean, but its spread will be much 
smaller than that of the original population with smaller spreads occurring for larger sample sizes. 

 
 
Wrap Up 
Upon completion of the lesson, the teacher should ensure that students are able to understand: 
• Elements sampled from a normal population vary according to that normal distribution. 
• Means of different samples of a fixed size from a given population vary but differently from the 

individual elements from the population. 
• The simulated sampling distribution of sample means looks approximately normally distributed. 
• As sample size increases, variability in the sampling distribution of sample means decreases. 
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TI-Nspire Navigator 
Note 1 
Question 3, Class Capture and Quick Poll 
A Class Capture would allow students to see other results and note the variability. Another good 
alternative would be to send a Quick Poll to collect each student’s displayed  value.  
 
Note 2 
Question 8, Class Capture 
Using Class Capture can reinforce the idea that sample means vary from sample to sample, but that they 
do so in a somewhat predictable manner. Students should notice that while their individual graphs will be 
different in detail, most will be centered somewhere near 0, and the spreads of their plots will be about 
the same. 
 
Note 3 
Before Question 9, Quick Poll 
Send students a screen shot of page 3.3 and ask them to predict what the mean and standard deviation 
should be. Show the results, without comment.  Have them take 5 minutes to convince a partner that their 
prediction is correct.  Then resend the Quick Poll. Show the results and have students discuss what they 
were thinking when they made the prediction.  Then go to page 3.3 and have them test their predictions. 
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Open the TI-Nspire document Conditional_Probability.tns. 
 
Sometimes additional information can help you narrow the probability 
that an outcome will occur. This activity allows you to investigate this 
situation and to see how extra information can make a difference. 

 
 

 
In 1992, Life magazine published an article entitled “If Women Ran America” which reported the 
results of a poll of U.S. men and women asked whether the problem of unequal pay for equal work 
is a serious one in our country. Suppose the poll was given to 44 people, 20 males and 24 females, 
and that 26 of the people polled agreed that the problem of unequal pay for equal work is serious. 
1. Suppose further that 10 of the males agreed that the problem is serious. 

a. Indicate which of the table cells below you could fill in with this information. 
 

Gender/ problem Yes No Row Totals  
Male    
Female    
Column Totals    

 

 
Move to page 1.2. 
 

b. On this Lists & Spreadsheet page, enter 10 into the cell representing the number of males who 
agree the problem is serious, and compare the resulting table to your answer to part a. 

 
2. a. If a person is chosen randomly from the 44 people, what is the probability that the person is a 

male? 
 
 

b. What is the probability that the person is male and the person agrees that the problem is 
serious? 

 
Move to page 1.3. 
 
3. Page 1.3 shows both the table and a graphical representation of the data in the table. Select the 

bars in the graph. 
a. Based on the probabilities you see, which outcome is most likely, and what is the probability of 

that outcome? 
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b. The two blue bars are the same height. Do they represent the same probabilities? 
Why or why not? 

 
 
4. What is the probability that a person chosen at random from those who agree the problem is serious 

is a male? Explain how you can get this answer from the table and from the graph. 
 
 
5. Assume the row and column totals remain fixed (that is, there are a total of 44 people in the 

survey, 24 are female, and 26 of the 44 agree that the problem of unequal pay for equal work is 
serious. A person is chosen at random from the 44 people, and you know that the person 
chosen agrees that the problem of unequal pay for equal work is serious. Given this 
information, enter different values in the table to find the following: 
a. The maximum probability that the person is a male. Explain why this is the maximum. 
 
 
b. The minimum probability that the person is a male. Explain why this is the minimum. 
 

 
Suppose 8 men agreed that the problem is serious. Enter 8 in the appropriate cell in the table. 

 
Move to page 1.4. 
 

6. Explain the differences in the two graphs. 
 
 
7. Identify the graph you would use to answer each of the following questions, and then answer 

the question. A newspaper randomly chooses a person to be interviewed from the 44 who were 
given the poll. What is the probability that: 
a.  The person agrees that the problem of unequal pay for equal work is serious, given that the 

person is male. 
 
 
b. The person is male, given the person does not agree that the problem of unequal pay for 

equal work is serious. 
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c. The person does not agree that the problem of unequal pay for equal work is serious. 
 
 

d.  The person does not agree that the problem of unequal pay for equal work is serious given that 
the person is female. 

 
 

e.  The person is male and the person agrees that the problem of unequal pay for equal work is 
serious. 

 
 

f.  The person is female or the person agrees that the problem of unequal pay for equal work is 
serious. 

 

8. Some probability questions ask for the probability of a single outcome out of the total number 
possible. Some ask for the probability of a single outcome with a given condition. Others ask for the 
probability of an outcome that has compound (satisfies a and/or b) conditions. Categorize the 
situations from Question 7 into the table below according to the nature of the question. 

 

Question 
Single outcome 

out of total possible 
Single outcome 

with a given condition  
Outcome with 

compound conditions 
a    
b    
c    
d    
e    
f    

  
9. a. Describe how you would identify a probability question where the denominator is not the total 

number of outcomes. 
 
 

b. If A and B are two distinct outcomes, what is the difference between the probability of A given B 
and the probability of B given A? 

 

65



 

This page intentionally left blank 

 

66



 Conditional Probability  TEACHER NOTES 

MATH NSPIRED   
 

©2014 Texas Instruments Incorporated 1 education.ti.com 

Math Objectives 
• Students will identify the difference between the probability of an 

outcome and the conditional probability of an outcome. 
• Students will interpret information presented in a two-way table 

and in a corresponding bar graph. 
• Students will reason abstractly and quantitatively (CCSS 

Mathematical Practices). 
 
Vocabulary 
• conditional probability • two-way table 
• probability  

 
About the Lesson 
• This lesson involves thinking about probability when additional 

information is given. As a result, students will: 
• Investigate probability questions using tabular and 

graphical information. 
• Explain why a two-way table with two rows and two 

columns with fixed row and column totals needs only one 
input to determine the others. 

• Answer questions about the probability of an outcome 
using data from a two-way table. 

• Use bar graphs separated according to categories to 
answer probabilities and connect these graphs to 
information of the form P(A|B). 

• Choose between information presented as the probability of 
A given B and the probability of B given A (A|B and B|A) to 
answer specific probability questions. 

 

TI-Nspire™ Navigator™ 
• Send out the Conditional_Probability.tns file. 
• Monitor student progress using Class Capture. 
• Use Live Presenter to spotlight student answers. 
 
Activity Materials 

• Compatible TI Technologies : TI-Nspire™ CX Handhelds, 

TI-Nspire™ Apps for iPad®, TI-Nspire™ Software 

 
 
Tech Tips: 
• This activity includes class 

captures taken from the    
TI-Nspire CX handheld. It is 
also appropriate for use with 
the TI-Nspire family of 
products including TI-Nspire 
software and TI-Nspire 
Apps. Slight variations to 
these directions might be 
required if using other 
technologies besides the 
handheld. 

• Watch for additional Tech 
Tips throughout the activity 
for the specific technology 
you are using. 

• Access free tutorials at 
http://education.ti.com/ 
calculators/pd/US/Online-
Learning/Tutorials  

 
Lesson Files: 
Student Activity 
• Conditional_Probability_ 

Student.pdf 
• Conditional_Probability_ 

Student.doc 

TI-Nspire document  
• Conditional_Probability.tns 
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Discussion Points and Possible Answers 
 

 
 

Teacher Tip: The lesson would be a good precursor to lay the foundation 

for the formal definition of conditional probability, ( )( | )
( )

P A BP A B
P B
∩

=  or 

work with Baye's Theorem. However, for this lesson, students should at 
least be familiar with the concept of probability. 
This activity lends itself to the use of PublishView, which gives you an 
opportunity to display the two-way table (Page 1.2) and the two bar graphs 
(Page 1.4) simultaneously so the students can manipulate the two-way 
table and see how the two sets of bar graphs change dynamically. 

 
Teacher Tip: The lesson is based on an actual poll reported in the June 
1992 Life magazine article “If Women Ran America.”  One possible 
extension at the end of the lesson might be to have students take a poll 
and compare the results today from those in 1992. 

 
 
In 1992, Life magazine published an article entitled “If Women Ran America”, which reported the 
results of a poll of U.S. men and women asked whether the problem of unequal pay for equal work 
is a serious one in our country. Suppose the poll was given to 44 people, 20 males and 24 females, 
and that 26 of the people polled agreed that the problem of unequal pay for equal work is serious. 
1. Suppose further that 10 of the males agreed the problem is serious. 

a. Indicate which of the table cells below you could fill in with this information. 
 

Sample Answers: 
 

Gender/ problem yes No Row Totals  
Male 10 10 20 
Female 16 8 24 
Column Totals 26 18 44 

 

Move to page 1.2. 
 

b. On this Lists & Spreadsheet page, enter 10 into the cell 
representing the number of males who agree the problem is 
serious, and compare the resulting table to your answer to 
part a. 
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Sample Answers: The worksheet table and the table in the TI-Nspire document should match. 
Note that one entry in any cell will determine the other cell because the totals for the row and 
column containing that cell have to be preserved. 

 

Tech Tip: To hide the keyboard after entering a value into the 

spreadsheet, press the keyboard down button in the lower right corner . 
 

Tech Tip: To add or modify the data in a spreadsheet cell, double-tap 
the cell. 

 

Tech Tip: Students might want to use the calculator Scratchpad to 
find the probabilities in question 2. 

 
2. a. If a person is chosen randomly from the 44 people, what is the probability that the person is a 

male? 
 

Sample Answer: 20/44 or 0.4545… 
 
b. What is the probability that the person is male and the person agrees the problem is serious? 

 

Sample Answer: 10
44

 or 0.227273… 

 
Move to page 1.3. 
 
3. Page 1.3 shows both the table and a graphical representation of 

the data in the table. Select the bars in the graph. 
a. Based on the probabilities you see, which outcome is most 

likely, and what is the probability of that outcome? 
 

Sample Answer: The outcome that is most likely (0.615 or 
61.5%) is a female who agrees the problem is serious. 

 

 

Teacher Tip: Students might think that the highest bar will always 
represent the greatest probability of occurring. The next question should 
address this concern, but it is important to be sure this possible 
misconception is made clear. 
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b. The two blue bars are the same height. Do they represent the same probabilities? 
Why or why not? 

 
Sample Answer: The frequency of both bars is 10, but they represent different things. The blue 
bar to the left represents the 10 males of the 26 (38.5%) people who answered yes, while the 
blue bar to the right represents the 10 males out of the total number, 18, (55.6%) who said no. 
 

4. What is the probability that a person chosen at random from those who agree the problem is 
serious is a male? Explain how you can get this answer from the table and from the graph. 

 
Sample Answer: 10 out of 26 or 38.5% are male, given the person agrees the problem is 
serious. From the table, use the "yes" column total for the denominator, and use the number of 
males in that column for the numerator. Using the graph, you would go to the two bars over the 
label "yes," and choose the bar representing the males. 

 
5. Assume the row and column totals remain fixed (that is, there are a total of 44 people in the 

survey, 24 are female and 26 of the 44 agree that the problem of unequal pay for equal work is 
serious. A person is chosen at random from the 44 people, and you know that the person 
chosen agrees that the problem of unequal pay for equal work is serious. Given this 
information, enter different values in the table to find the following: 
a. The maximum probability that the person is a male. Explain why this is the maximum. 

 
Sample Answer: The maximum possible value for the cell representing male and agreeing 
the problem is serious is 20 because the total number of males is 20. There are 26 people 
all together who answered ‘yes’ to the survey. Thus, the maximum probability the person is 
a male is 20/26 or about 0.769231 (76.9%). 

 
b. The minimum probability that the person is a male. Explain why this is the minimum. 

 
Sample Answer: The minimum possible value for the cell representing male and agreeing 
the problem is serious is 2 because there are 24 females and a total of 26 people who 
answered ‘yes’ to the survey. Thus, the minimum probability the person is a male is 2/26 or 
about 0.076923 (7.7%). 
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Suppose eight men agreed that the problem is serious. Enter 8 in the 
appropriate cell in the table. 

Move to page 1.4. 
 

6. Explain the differences in the two graphs. 
 

 
Sample Answer: The graph in the left panel assumes you know whether the person is a male or 
a female and from that assumption, shows the probability the person thinks the problem of 
unequal pay for equal work is serious (assumed: gender; probability: yes/no). The graph in the 
right panel assumes you know whether the person agrees or does not agree that the problem is 
serious and based on that knowledge, shows the probability the person is male or female 
(assumed yes/no; probability: gender). 

 
Teacher Tip: This is a good place to have a discussion about what 
information is considered “given” or “assumed” in each set of bar graphs. 

 
7. Identify the graph you would use to answer each of the following questions, and then answer 

the question. A newspaper randomly chooses a person to be interviewed from the 44 who were 
given the poll. What is the probability that: 
a.  The person agrees that the problem of unequal pay for equal work is serious, given that the 

person is male. 
 

Sample Answer: The panel on the left, split by gender on the horizontal axis; 8
20

 = 40%. 

 
b.  The person is male, given the person does not agree that the problem of unequal pay for 

equal work is serious. 
 

Sample Answer: The panel on the right, split by yes or no to whether the problem is serious 

on the horizontal axis: 12
18

 or 66.7%. 

 
c.  The person does not agree that the problem of unequal pay for equal work is serious. 

 
Sample Answer: Either graph would work as you would have to read the frequencies from 
two of the bars to capture both males and females who answered no to the question of 
whether the problem is serious and then divide by the total number of people in the survey 
to obtain 18/44=40.9%. 
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d.  The person does not agree that the problem of unequal pay for equal work is serious given that 
the person is female. 

 

Sample Answer: The panel on the left, split by gender: 6
24

 or 25%. 

 
e.  The person is male and the person agrees that the problem of unequal pay for equal work is 

serious. 
 

Sample Answers: Either panel, looking for both male and the answer yes to whether the 
problem is serious. But the denominator is 44, which has to come from the total of all the 

people surveyed; 8
44

 = 18.2%. 

 
f.  The person is female or the person agrees that the problem of unequal pay for equal work is 

serious. 
 

Sample Answer: Either panel can give the answer by adding up the number who are female 
and who answered yes to whether the problem is serious. Students should be careful not to 

count the overlap between females and those who answered yes; 32
44

 = 72.7%. 

 
8. Some probability questions ask for the probability of a single outcome out of the total number 

possible. Some ask for the probability of a single outcome with a given condition. Others ask for the 
probability of an outcome that has compound (satisfies a and/or b) conditions. Categorize the 
situations from Question 7 into the table below according to the nature of the question. 

 
Sample Answers: 

 

Question 
Single outcome 

out of total possible 
Single outcome 

with a given condition  
Outcome with 

compound conditions 
a  x  
b  x  
c x   
d  x  
e   x 
f   x 

 

 
Teacher Tip: You might want to spend more time exploring P(A and B) 
and P(A or B) using the data in the table at a later time. The focus of this 
activity is just on conditional probability. 
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Teacher Tip: This activity does not use the formal notation: P(A|B). If you 
choose to introduce the notation it might be better to wait until the end of 
the activity in order to make sure the concept is well understood before 
students have to decipher the notation. In many situations, the words 
should enable students to understand when a conditional probability is 
involved. 

 
9. a. Describe how you would identify a probability question where the denominator is not the total 

number of outcomes. 
 

Sample Answer: When the question is based on knowing some given information, you use 
the subset of the total number of outcomes that specifies that given set; for example, when the 
problem says, given A, find the probability of B. 

 
b. If A and B are two distinct outcomes, what is the difference between the probability of A given B 

and the probability of B given A? 
 

Sample Answer: The probability of A given B says you only look for As in the set of all 
possible Bs. The probability of B given A says you look for Bs in the set of all possible As. The 
numerator in both cases will be the same, the intersection of A and B, but the denominator in 
the first case will be the number of outcomes that are B and, in the second case, the number 
of outcomes that are A. 

 
Teacher Tip: You might want to put the two-way table on the board and 
have the students display the bar graphs on their handhelds. Make sure 
they understand how the bar graphs connect with the table. In one case 
when you are given the gender, you are considering the row totals. In the 
other case, when you are given the knowledge “if a person agrees the 
problem is serious” then you are considering the column totals. 

 
Extension 

The actual results of the survey were that 1
2

 of the men agreed the problem of unequal pay for equal 

work was serious, while 2
3

 of the women did. Refer to the Math Nspired Statistics activity Two-way 

Tables and Association to decide whether men and women really have different opinions about whether 
equal pay for equal work is a problem. 
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Wrap Up 
Upon completion of the lesson, the teacher should ensure that students are able to understand: 

• The difference between probability of an outcome and the conditional probability of an outcome. 
• How to interpret values in a two-way table. 
• How to compute probabilities and conditional probabilities from graphs and tables. 

 
 
Assessment 
Identify each of the following as sometimes true, always true, or never true. Be prepared to justify your 
reasoning. 
 

1.  The probability of A given B is the same as the probability of B given A. 
 
Answer: Sometimes true. It is true if the number of outcomes for A and for B is the same number. 

 

2. If the row and column totals of a two-way table with two rows and two columns are constant, 
knowing one of the cells is sufficient to complete all of the cells in the table. 
 
Answer: Always true. 

 

3.  Answer the questions below given the following conditions: the row and column totals remain 
constant; the entry in each cell is different. 

 
 C D  

A   35 
B   42 
 20 57 77 

 
a. The probability of A given C is 20/35. 
 

Answer: Never true. Given C means the denominator has to be 20. 
 

b. The probability of C given B will be the value in the cell for B and C (row B, column C) divided 
by 42. 

 
Answer: Always true. 
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TI-Nspire Navigator 
Quick Poll can be used to assess student understanding. The questions above could be used to do this. 
Another approach is to display a two-way table or bar graphs similar to the ones in the exercise and use 
Quick Poll to collect students’ responses to probability questions. 
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Activity Overview 
In this activity you will become familiar with the most commonly used keys on the TI-Nspire™ CX family of 
handhelds. 
 
 

 
 
 
 

10  

9 

1 2 3 

4 

5 8 

6 7 
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Activity Overview 
In this activity, you will explore basic features of the TI-Nspire™ Teacher Software. You will explore the 
Welcome Screen, add pages with Calculator and Graphs applications, and explore the menus and 
submenus of each application. You will explore the five tabs within the Documents Toolbox, as well as the 
options available in the Documents toolbar and the Status bar. 
 
 

Materials 
• TI-Nspire™ or TI-Nspire™ CAS Teacher Software 

 
 
 

Step 1: 

Open the Teacher Software. The Welcome Screen 
displays an icon for each of the eight applications: 
Calculator, Graphs, Geometry, Lists & Spreadsheet, 
Data & Statistics, Notes, Vernier DataQuest™, and 
Question. To see a brief description of each 
application, hover the cursor over each icon.  

 

The Welcome Screen also allows you to view content, manage handhelds, transfer 
documents, and open documents. To see a description of each option, hover the cursor 
over each icon. To view the Welcome Screen at any time, go to Help > Welcome Screen.  
 
A new TI-Nspire™ document may be opened by clicking any of the applications on the Welcome Screen. 
Alternatively, a new document may be opened by going to File and selecting New TI-Nspire™ 
Document – Handheld Page Size or New TI-Nspire™ Document – Computer Page Size. 

• The Handheld Page Size allows documents to be viewed on all platforms. The content will be 
scaled when viewed on a tablet or larger screen. 

• In Computer Page Size, content will not be scaled when viewed on smaller platforms and all 
content may not be visible on a handheld device. 

 
Step 2:  
Go to File > New TI-Nspire™ Document – Handheld Page Size.  Select  1:Add Calculator. 
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Step 3: 

The Calculator application allows you to enter and evaluate 
mathematical expressions as well as create functions and 
programs. 
 
In most cases, each application has a unique menu of 
commands and tools. To view the Calculator menu, go to the 
Documents Toolbox and select the  Document Tools tab. 
Each item in the Calculator menu has a submenu.  
 
Explore the various menus and submenus by entering and 
evaluating your own expressions. 
 
Note: To access the Calculator menu on the handheld, 

press b. 

  

Step 4: 

The  Utilities tab contains Math Templates, Symbols, 
Catalog, Math Operators, and Libraries panes. Only one pane is 
displayed at a time, and the Math Templates pane is the default 
pane. Explore each of the other panes by clicking them. 
 
To insert a Math Template into the Calculator application, 
double-click it. Explore various Math Templates by evaluating 
your own expressions involving fractions, exponents, square 
roots, logarithms, and absolute value expressions. 
 
Note: When evaluating expressions, the Calculator application 

displays rational expressions by default. To display a 
decimal approximation on a PC, press CTRL + Enter. 
To display a decimal approximation on a Mac, press 
Command + Enter. 

 

 

80



 Getting Started with the TI-Nspire™ Teacher Software 
TI PROFESSIONAL DEVELOPMENT 

 

 

©2014 Texas Instruments Incorporated 3 education.ti.com 

Step 5: 

The  Insert menu allows you to insert 
problems and pages, along with each of the eight 
applications. A problem can contain multiple 
pages, and variables that are linked within a 
problem are linked across pages.  
 
Insert a Graphs application by selecting  Insert > 

 Graphs.  
 
The Graphs application allows you to graph and 
analyze relations and functions. Explore the 
various menus and submenus available in the 
Graphs application. 
  

Step 6: 

Graph the function f(x) = x by typing x into the 
function entry line and pressing Enter. 
 
Rotate the line by hovering the cursor over the 
upper-right or lower-left corner of the graph. When 
the rotational cursor, é, appears, rotate the line 

by clicking and dragging it. 
 
Translate the line by hovering the cursor over the 
line near the y-intercept of the graph. When the 
translational cursor, ö, appears, translate the line 

up or down by clicking and dragging it. 
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Step 7: 

Since you have inserted a Calculator application 
and a Graphs application, your TI-Nspire™ 
document now has two pages. The Page Sorter 
view allows you to view thumbnail images of all 
pages in the current TI-Nspire document. 
 
Access the Page Sorter by going to the 

Documents Toolbox and clicking the  Page 
Sorter tab. Pages can be rearranged by grabbing 
and moving them. Right-clicking allows for pages 
to be cut, copied, and pasted. 
 
Note: To access Page Sorter in the handheld, 

press /£. To right-click in the 
handheld, press /b. 

 

 

Step 8: 

The Vernier DataQuest™ app can be used to 
collect, view, and analyze real-world data. Insert a 
page with the Vernier DataQuest app by selecting 

 Insert >  Vernier DataQuestTM. 
 
Though no data will be collected during this 
activity, the data meter will automatically launch 
when a Vernier sensor is connected to the 
computer’s USB port. 
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Step 9: 

The Documents toolbar allows you to create, open, and save a TI-Nspire document. 
Commands such as Undo, Redo, Cut, Copy, and Paste are also available. Explore these 
options by hovering the cursor over each icon. Pages, problems, and applications can be 
inserted and variables can be stored.  
 
Take a Screen Capture of the current page by selecting  Take Screen Capture >  

Capture Page. This Screen Capture can be saved as an image. 
 

 
 
Page layouts allow multiple applications to appear on one screen. Explore the various 
page layouts that are available by clicking  Page Layout.  

The Document Tools menu contains tools and commands for the 
current application. 
 
To change the fill color, line color, or text color, select an object 
and then select a color from the appropriate menu. To receive 
additional information about a given menu, hover the cursor over 
it. Not all color menus are available on all applications. 
 

 

 

Step 10: 

The Status Bar allows the user to access Document Properties, Settings, and to adjust the 
zoom of the SideScreen.  
 

 
 
Increase the zoom of the SideScreen to 200% by selecting 200% in the Zoom menu. The 
Boldness feature is enabled when using a PublishView™ document.  
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Step 11: 

View the Document Properties by going to File > 
Document Properties. The Document Properties 
also can be viewed by going to the Status Bar and 
double-clicking Page Size: Handheld or Page Size: 
Computer. The page size displayed depends upon 
the type of TI-Nspire document originally opened. 

 
 

Step 12: 

View the Document Settings by going to File > 
Settings > Document Settings. The Document 
Settings can also be viewed by going to the Status 
Bar and double-clicking Settings. 

 

Note: To move across fields in the Document Settings window, press TAB. To change the 
setting in a given field, press the down arrow, select the desired setting, and press 
TAB to move to the next field. To exit the window, press ENTER. 

Step 13: 

Preview the document in Handheld or Computer view by clicking                                    . 
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Step 14: 

To access the TI-SmartView™ emulator for TI-Nspire, 
go to the Documents Toolbox and select the 
  TI-SmartView tab. 
 
TI-SmartView emulator has three available views: 
Handheld only, Keypad + SideScreen, and Handheld + 
Side Screen. Explore each of these views. 
 
The TI-SmartView emulator has three available keypads:  

• TI-Nspire™ CX 
• TI-Nspire™ with Touchpad 
• TI-Nspire™ with Clickpad 

 
Each keypad has three available views: Normal, High 
Contrast, and Outline. Click the  Keypad Options 
menu and explore each keypad and view. 

 

Step 15: 

Documents can be transferred between the computer 
and connected handhelds using the Content Explorer 
in the Documents Workspace. Explore the Content 
Explorer by clicking the  Content Explorer tab. 
 
To transfer a TI-Nspire document from the computer to 
the connected handheld, locate the document in the 
Computer panel. Click, drag, and drop it into the 
desired handheld or folder in the Connected 
Handhelds panel. 

 
To transfer a TI-Nspire document from the connected 
handheld to the computer, locate the document in the 
Connected Handhelds panel. Click, drag, and drop it 
into the desired folder in the Computer panel. 
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Activity Overview 
In this activity, you will explore the Content Workspace of the TI-Nspire™ Teacher Software. You will 
browse web content, manage computer content, and transfer a document to a connected handheld. 
 
 

Materials 
• TI-Nspire™ or TI-Nspire™ CAS Teacher Software with internet connection 

• TI-Nspire™ handheld and standard-A to mini-B USB cable 
 
 
 
 

Computer Content, Links, and Web Content 
 
Step 1: 

Open the Teacher Software. If the Welcome Screen appears when 
the software is opened, go to the Content Workspace by clicking 
View Content. Otherwise, go to the Content Workspace by clicking 
the Content tab. 

 

 

 

 

 
Step 2: 

The Resources panel contains three types of resources: 
Computer Content, Links, and Web Content. If a handheld is 
connected to the computer, a fourth resource, Connected 
Handhelds, appears. Select Links. 

Note:    Each resource can be collapsed by clicking ¤ and 
expanded by clicking ¢. 

Step 3: 

The Content Workspace offers access to online resources through links to various websites. A list 
of links appears in the Content window. When a link is clicked, a Web browser is launched. Links 
can be added, edited, and removed by clicking the Add Link, Edit Link, and Remove Link icons.  
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Step 4: 

The Content Workspace offers the ability to search for lessons available online at Math Nspired or 
Science Nspired. In the Resources panel, go to Web Content and select Math Nspired or Science 
Nspired. The Content pane toolbar contains cascading fields for Subject, Topic, and Category. 
Activities can also be located using the Filter by keyword field.  

 

Step 5: 

Once a lesson is located, details about the activity appear in the Preview pane. The activity might 
appear as a lesson bundle, which consists of multiple files and can contain multiple file types. If the 
activity is a lesson bundle, the Files window appears and lists the individual files in the lesson bundle. 

 
Save the lesson bundle to your Desktop by clicking Save this Activity to Computer. To 
save an individual file, right-click it and select Save to Computer. 

 

Step 6: 

In the Resources panel, go to Computer Content. Here, you have the ability to view the documents 
and folders available on the Desktop, in the My Documents folder, and in the TI-Nspire folder. 

 
The Content pane toolbar provides tools needed to locate folders and files. The Look in field 

contains the path of the current folder or file. To move up a level in the folder hierarchy, click . 

To create a new folder, click . To search for a document containing a specific word, use the 
keyword field. 
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Step 7: 

When a TI-Nspire™ document is selected, the first page of the document appears in the Preview 
pane. If the document has multiple pages, the forward arrow can be used to preview additional 
pages. To open a TI-Nspire document in the Teacher Software, double-click it. 

 

 

Step 8: 

To create a lesson bundle, click the Create a New Lesson Bundle icon on the Content 
Workspace toolbar. Click Add Files to Lesson Bundle and a dialogue box appears that allows you 
to browse local content. Select a file and click Add. Once a TI-Nspire document is added to the 
lesson bundle, click the name of the document and the first page appears in the preview pane. 

 

 

Transferring Documents to Connected Handhelds 

 

Step 9: 

Connect a TI-Nspire™ handheld to the computer using the USB 
connection cable. In the Resources panel, click Connected 
Handhelds. 

 
Note: Multiple handhelds can be connected to the computer 

using multiple USB ports, USB hubs, or the TI-Nspire™ 
Docking Station. If multiple handhelds are connected to 
the computer, then multiple handhelds appear in the list 
of Connected Handhelds. 
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Step 10: 

The connected handheld appears in the Content window, along with battery, storage, and OS 
information. To view the documents on a connected handheld, right-click it and select Open. The 
handheld can also be renamed, its screen can be captured, and the OS can be checked and updated. 

 

Step 11: 

Locate a TI-Nspire document on your computer by browsing Computer Content in the Resources 
panel. Send the document by dragging and dropping it to the connected handheld. The document can 
also be sent by right-clicking the document name and selecting Send to Connected Handhelds. 
 
Note:    When sending multiple documents, locate the first document in the Content Window and 

select   Send to Connected Handhelds. 

 

Step 12: 

Upon selecting Send to Connected Handhelds, the 
Transfer Tool window appears. To add an additional 
document, select Add to Transfer List and locate the 
additional document. To remove a document, select the 
document and click Remove Selected. 

 

To change the destination folder, select the document and go to the Edit Destination Folder field. 
To identify an existing folder, select it from the drop-down menu and click Change. To create a new 
folder, type its name into the field and click Change. To send the document to the handheld, click 
Start Transfer. Once the Status tab indicates that the transfer is complete, click Stop Transfer. 
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Converting Fractions to Decimals 
 
Insert a Calculator page: 
Press /I and choose Add Calculator. 

  
Use the quadratic formula to solve  
f(x) = 6x2 + x – 2 on the Calculator page. 
TI-Nspire™ defaults to a fraction result. 
Copy and paste the expression by using the 
up arrow on the Touchpad (£) to highlight, 
then press ·. 

  
Method 1: Do you see the small Þ 

(approximate) symbol above the · key? 
Activate the Approximate command by 
pressing /·. 
Method 2: Insert a decimal point ^ in the 
expression. 

  
Copy and paste the expression and edit the 
expression to find the other root.  
Method 3: Position the cursor after the 
expression and press Menu > Number > 
Convert to Decimal. 

  
Method 4: Find the Approximate 
command in the Catalog. Press k, then 
press A to locate the commands that 
begin with A (make sure you are in tab 1). 
Use the Touchpad arrows to locate the 
command, press · to choose approx(, 
then copy and paste the expression.   

Method 5: Type approx( using the alpha 
letters on the keypad 
(APPROX(), then copy and paste 
the expression. Notice the letters are in 
italics until the full command has been 
entered. 
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Grabbing and Moving a Point 

Insert a Geometry page:  
Press /I and choose Add Geometry. 
To construct a triangle, press Menu > 
Shapes > Triangle.  
Hover over the Triangle icon in the upper 
left corner to read the Tool Tip.  
Click (x) in three locations on the screen 
to construct the triangle. 
Press d to exit the Triangle tool. 

  

  
Grab a point using Method 1: 
Hover over the point until you see the word 
point appear. Press and hold x for one 
second. The hand becomes closed over the 
point. Move the Touchpad as desired to 
move the point. Press d to drop the point 
at the desired location.   

Hover over the point until you see the word 
point appear. Press e if you want to use 
the object underneath the point (in this 
case, the triangle). 
 
Grab a point using Method 2: 
Press /x to close the hand and grab 
the point.  

  

Once the point is grabbed, you can move 
the point by using the arrow keys ¡ ¢£¤ 
on the Touchpad. Alternatively, you can 
swipe your finger across the Touchpad to 
move the point more quickly. 
Press d to let go of the point. 

  
Try moving the whole triangle by grabbing 
one of its sides. 
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Finding Points of Interest 

Start a New Document:  
Press c and choose New Document. 
You are prompted with the question, “Do 
you want to save?” Say No by pressing 
e to advance to the next field; then press 
· or x to make the selection. Choose 
Add Graphs.   

Graph the function f1(x) = x4 + x3 – 4x2 + 4. 
 
Method 1: Open the Trace tool by pressing 
Menu > Trace > Graph Trace. 
Use the ¡ ¢ arrows on the Touchpad to find 
the local minimum, maximum, and zeros of 
the function. It is common for new users to 
try (unsuccessfully) to use the £ ¤ keys to 
operate the Trace tool. Only use the left 
and right arrow keys! 

  

  
Hover over the Graph Trace icon in the top 
left corner of the screen. The Tool Tip 
explains how to use the tool. 
While in Trace mode, type a number to 
“jump” to that value of x on the graph.  

  
Method 2: While the Trace tool is open, 
drop a point on the graph by pressing ·. 
Grab (/x) and move the point to 
locate the zero. 
Hover over the x-coordinate of the point and 
press + or - repeatedly to see more (or 
fewer) decimal places displayed.   

Method 3: Open the Analyze tool by 
pressing Menu > Analyze Graph > 
Minimum.  
Click (x) to mark the lower bound of the 
search region, use the Touchpad arrows  
(¡  ¢) to move, and press · to identify 
the interval in which to display the 
minimum.  
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Using a Table 

Start a New Document:  
Press c and choose New Document. 
You are prompted with the question, “Do 
you want to save?” Say No by pressing 
e to advance to the next field; then 
press · or x to make the selection. 
Choose Add Graphs.    

Graph the function f1(x) = x2 –2. 
Method 1: Press /T to insert a table. 
Method 2: Press Menu > Table > Split-
screen Table. 

  
To edit the table settings, press Menu > 
Table > Edit Table Settings. Change the 
Table Start to 1.2 and the Table Step to 0.1 
to find the roots of the function numerically. 

  
Change the table settings so that you can 
type in any x-value you wish.  
Press Menu > Table > Edit Table 
Settings. Change the Independent variable 
to Ask. 

  
Press /T to remove the table. 

  

Graph the function f2(x) = x – 2. 
Press /I and add a Lists & 
Spreadsheet page. To see the table for 
multiple functions, press /T, choose 
the function, and then press ¢ to navigate 
to the next column and choose another 
function.   
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Graphing a Scatter Plot 

Start a New Document:  
Press c and choose New Document. 
You are prompted with the question, “Do 
you want to save?” Say No by pressing 
e to advance to the next field; press 
· or x to make the selection. Choose 
Add Lists & Spreadsheet.    
You must name your lists (which many 
users forget to do). 
Name the lists xc and yc (for x and y-
coordinates). Enter {15,20,25,30,35} in list 
xc and {70,76,84,91,100} in list yc. 

  
Method 1: To select both columns, move 
your cursor over the A at the top of the 
column and press x. Then hold g 
and press ¢ to highlight column B as well. 
(Alternatively, press £ until column A is 
highlighted, then hold g and press ¢ to 
highlight column B.) Right-click (/b) 
and choose Data > Quick Graph.  

  

Method 2: Press ~  > Insert > Data & 
Statistics. Click (x) near the bottom of 
the screen, where it says “Click to add 
variable,” and choose xc. Move your 
cursor to the left side of the screen, click 
(x), and choose yc. 

  
Method 3: Press /I and choose Add 
Graphs. Press Menu > Graph Entry/Edit 
> Scatter Plot.  
Press h and choose xc for the x list and 
yc for the y list. Press · to graph the 
scatter plot. 

  
What? You can’t see your graph? 
Press Menu > Window/Zoom > Zoom 
Data. 
Since a Graphs page does not 
automatically keep the axes in view, you 
may want to grab the axes and move 
toward the origin to zoom out.   
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Adjusting the Settings 

One way to access the settings is to click 
(x) on the battery/tool icon in the top-right 
corner of the screen. Choosing Status 
shows a screen containing the version of 
your operating system, as well as 
information about your battery life and 
available memory.   

Another way to access the settings is to 
press c > Settings. To change the 
Calculator settings, choose Document 
Settings. Use the e key to navigate to 
the next field (like a computer). Click (x) 
or press ¢ to make a change to one of the 
settings.   

Warning! If you click the OK button, the 
settings of your Scratchpad will not change! 
However, if you e down to Make Default, 
you will receive a prompt asking if you want 
to apply the setting changes to the 
Scratchpad. Click OK to do so. 

  
Sometimes there is some confusion about 
the Display Digits setting. The Fix 2 
command will automatically show two 
decimal places of any expression with a 
decimal. Use this setting when you are 
working with money problems and want to 
include cents in the result.   

In contrast, the Float 2 command will show 
at most two digits of any expression that 
contains a decimal.  
Insert a Graphs (or Geometry) page and 
press Menu > Settings to access the 
settings for a Graphs or Geometry 
application.   
Press ~ > Settings & Status > 
Handheld Setup. You can also click (x) 
the triangle next to the document name at 
the top of the page to open the Documents 
menu. Use the Handheld Setup menu to 
change the font size and adjust the power 
settings of your handheld.   
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Graphical Representations of Data 

Start a New Document:  
Press c and choose New Document. 
You are prompted with the question, “Do 
you want to save?” Say No by pressing 
e to advance to the next field and then 
· or x to make the selection. Choose 
Add Lists & Spreadsheet.     

Name column A first_period. Populate the 
list with the following test scores: {71, 83, 
80, 95, 77, 98, 65, 86, 77, 83, 83, 89, 95, 
72, 83}. Resize the column by grabbing 
near the top of the screen in between 
columns A and B (look for the ô symbol). 

  
Press Menu > Data > Quick Graph to 
create a dot plot of the data. 
Right-click (/b) and choose Box 
Plot (or Histogram if you prefer).  
Press /I and Add Lists & 
Spreadsheet. 

  
Title the first list school {fresh, soph, junior, 
senior} and title the second list number 
{680, 455, 534, 523}. Press Menu > Data > 
Summary Plot and configure the dialog 
box as shown. Right-click (/b) and 
choose Pie Chart. 

  
Press /I and Add Lists & 
Spreadsheet. 
Title the first list lunch {turkey, salad, pb_j, 
ham}. Title the second list boys {30, 4, 15, 
19}. Title the third list girls {15, 28, 8, 20}. 
Press /I and Add Data & Statistics. 
Click near the bottom of the page and 
choose lunch. 

  

Choose Add Y Summary List by right-
clicking (/b) in the box on the left, 
and choose boys. Repeat (or press Menu 
> Plot Properties > Add Y Summary List) 
and choose girls. Change the color of the 
bars by right-clicking and choosing Color > 
Fill Color.   
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Determining a Line of Best Fit 

Start a New Document:  
Press c > New Document > Add 
Graphs. Graph the function f(x) = x. Hover 
the cursor over the function until you see ö 
or é, and press /x. Use the Touchpad 
arrow keys to transform the function. 

  
Press /I and choose Add Lists & 
Spreadsheet. Title the first list xc {5, 10, 15, 
20, 25}. Title the second list yc {15, 44, 60, 
74, 105}. Press ~ > Insert > Data & 
Statistics. Choose xc and yc in the boxes 
where it says “Click to add variable.” Press 
Menu > Analyze > Add Movable Line.   

If you grab (/x) the movable line near 
the center of the line, you can translate it 
horizontally or vertically. Grab near either 
end to change its slope. 
Click on the movable line and press . to 
remove it. Press Menu > Analyze > 
Regression > Show Linear(mx+b).   

Press Menu > Analyze > Residuals > Show 
Residual Squares.  
To show the residual plot, press Menu > 
Analyze > Residuals > Plot 
Residuals. Note: You cannot calculate a 
regression on a Graphs page. 

  
Press /I and select Add Calculator. To 
perform a regression on a Calculator page, 
press Menu > Statistics > Stat 
Calculations >Linear Regression(mx+b). 
Configure the dialog box as shown. Notice 
that the regression will be stored in f2. 

  
Press /I and Add Lists & 
Spreadsheet. Press Menu > Statistics > 
Stat Calculations > Linear 
Regression(mx+b). Press /I and 
select Add Notes. Press /M to open a 
Math Box. Press Menu > Calculations > 
Statistics > Stat Calculations > Linear 
Regression(mx+b). 
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Working with Geometry Objects 

Insert a Geometry page:  
Press /I and choose Add Geometry. 
Press Menu > Shapes > Triangle. Click 
(x) to drop a point then type A to label the 
first vertex of the triangle. Click to drop 
another point and type B, then click to drop 
a final point and press C.   

To measure the lengths of the sides, press 
Menu > Measurement > Length. Hover 
over the Length icon to see the Tool Tip. 
Hover over a side of the triangle, press e 
until the word side appears, click once to 
measure, and click again to drop the 
measurement on the page.   

Construct an altitude in the triangle. Press 
Menu > Construction > Perpendicular. 
Click on point C and segment AB. Measure 
the right angle by pressing Menu > 
Measurement > Angle. Click the three 
points that form the angle, choosing the 
vertex second.   

To insert an Analytic Window, press Menu 
> View > Analytic Window. Hover over the 
end of an axis and press e until the word 
axes appears. Grab (/x) the end of 
the axis and use the Touchpad to resize the 
Analytic Window. 

  
Show the grid by pressing Menu > View > 
Grid > Lined Grid. Place a point on the grid 
by pressing Menu > Geometry > Points & 
Lines > Point On. Click twice to drop a 
point on the grid. Hide the grid by pressing 
Menu > View > Grid > No Grid. 

  
To insert a Geometry page, press  
/I and choose Add Geometry. 
Construct a circle with radius 4. First, right-
click (/b), choose Text, type 4, and 
then press ·. Press Menu > Shapes > 
Circle. Click on the 4, then click again to 
place the circle.   
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Using the Catalog 

Insert a Calculator page:  
Press /I and choose Add Calculator. 

  
Press k to open the Catalog. Press 1 to 
access the commands. If you want to use 
the Factor command, press F to jump to 
the commands that begin with the letter F. 
Press · to select the command that is 
highlighted. 

  

Some commands are difficult to remember 
how to use. Open the Catalog and locate 
the polyRoots command. Notice the syntax 
for the command at the bottom of the 
screen. Check the Wizards On box and 
click the chevron to see expanded syntax. 

  
Press 2 or click the second tab to access 
the commands organized by topic. This part 
of the Catalog is useful if you know the 
general topic of a command but forget what 
it is called. Click on the topic to expand and 
see which commands are available. 

  

Press 3 or click the third tab to access the 
Symbol palette. You can also access the 
Symbol palette by pressing /k on the 
keypad. There are 543 symbols. You may 
notice that using the catalog to access the 
symbols allows you to see more symbols at 
one time.   

Press 4 or click the fourth tab to access 
the Math templates. You can also access 
the Math templates by pressing t. The 
advantage of using the Catalog is that the 
template name appears near the bottom of 
the screen. 
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Adjusting the Window 

Insert a Graphs page:  
Press /I and choose Add Graphs. 

  

Graph the function f1(x) = x – 2 · (x + 10). 
Notice that you cannot see the whole 
parabola. Place your cursor in an open spot 
and grab (/x) the screen.  
Method 1: Use the Touchpad to move the 
entire coordinate plane. 

  

Method 2: Move your cursor over the axis 
until the word axes appears. Grab the axis 
(/x) and use your Touchpad to zoom 
out by dragging your hand towards the 
origin. 

  

You can change the scale on only one axis 
by holding down the g key as you drag 
the axis. 
Method 3: Double-click on the end values 
and change them. When you press · 
the changes will be reflected in the graphing 
window.   

If you want to change more than one of the 
end values, then after you change one (but 
before you press ·), press e to cycle 
to the next end value in a clockwise 
direction. 

  

Method 4: Press Menu > Window/Zoom > 
Window Settings and adjust as desired. 
Method 5: Use a Zoom feature. Press 
Menu > Window/Zoom > Zoom Fit. 
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Graphing f(y) Equations 

Insert a Graphs page:  
Press /I and choose Add Graphs. 

  
To insert a Text box, press Menu > Actions 
>Text and click in an open space. 
Alternatively, right-click (/b) in an 
open space and choose Text. 
 

  
Type an f(y) equation in the text box  
x = 3y + 2 and press ·. 
 
Grab (/a) and drag the text box to the 
x-axis to graph the f(y) equation. Drop the 
Text box on the x-axis to graph. 

  
Press /I and choose Add Graphs to 
add a new Graphs page. Graph the function 
f1(x) = x2. 
Insert a text box in an open space 
(/b and choose Text). Then type  
x = f1(y). 
 

  
Grab (/a) and drag the Text box to the 
x-axis. Drop the Text box on the x-axis to 
graph the inverse relation of f1. 
 
Double-click the f1(x) function label and edit 
it. Notice that the inverse relation updates 
automatically. 
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Calculating Points of Intersection 

Insert a Graphs page:  
Press /I and choose Add Graphs. 

  
Graph the function  f1(x) = x2. 
Press /G to open the entry line and 
graph the function 𝑓2(𝑥) = −1

3
𝑥 + 10

3
. 

  
Method 1: Press Menu > Geometry > 
Points & Lines > Intersection Points. 
Click on both graphs to calculate the points 
of intersection. 
Press d. Hover over the y-coordinate of 
the point and press + or - repeatedly to 
see more (or fewer) decimal places. 

  
Note: If you find the intersection point with 
an axis, the coordinates do not 
automatically show. Right-click (/b) 
on the point and choose Coordinates and 
Equations to label the ordered pair.  

  

Method 2: Press /d a few times to 
undo the intersection points you just found. 
Press Menu > Analyze Graph > 
Intersection. Click to the left of an 
intersection point to establish the lower 
bound. Then use the Touchpad to move to 
the right; click to establish the upper bound. 

  
Only one intersection point can be found at 
a time using the Analyze Graph menu.  
 
Repeat and choose different lower and 
upper bounds to find the other intersection 
point. 
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Managing Pages in a Document 

Insert a Graphs page:  
Press /I and choose Add Graphs. 
Insert a Geometry page:  
Press /I and choose Add Geometry. 
Insert a Lists & Spreadsheet page:  
Press /I and choose Add Lists & 
Spreadsheet.    

Access the Page Sorter view by pressing 
/£. This is a thumbnail view of the 
screens. You can change the order of the 
screens by grabbing a page (/x) and 
using your Touchpad to move it. 

  
You can copy (/C), cut (/X), paste 
(/V), and even delete (.) pages in 
this view. Click on the thumbnail and use 
the shortcut keystrokes to edit as desired. 

  

To copy and paste a whole problem, click 
on the Problem 1 label, press /C to 
copy, and then /V to paste. 
Delete an entire problem by clicking on the 
Problem label and pressing .. 

  

Click on a Graphs page thumbnail and 
enter f1(x) = x2. To split the screen, press 
~ > Page Layout > Select Layout > 
Layout 2. Then, move your cursor to the 
screen on the right, press Menu > Add 
Notes. 

  
Press ~ > Page Layout > Custom 
Split. Use your Touchpad to adjust the size 
of the split screen. Try using the Ungroup 
tool to separate the split screen into two 
separate pages. Press ~ > Page Layout 
> Ungroup (alternatively, press /6). 
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Updating the Operating System 

Check the operating system (OS) by pressing Menu > 
Settings > Status. In addition to the OS, notice the battery 
status, available memory and information regarding TI-
Nspire™ Navigator™ status. 

 

You can transfer an OS from one handheld to another. On the 
sending handheld, press c > My Documents. Then press 
Menu > Send OS. 

 

You can set your TI-Nspire™ Teacher Software to 
automatically check for handheld updates. On the software, 
click Help and choose Check for Handheld OS Update. If 
desired, click the box next to Automatically check for 
updates to have the handheld automatically check for updates 
to the OS when it is connected to the computer. 

 

You can also use your TI-Nspire Teacher Software to send out 
the OS to more than one handheld at once. Under the 
Content tab, Click the Send selected to icon and choose 
Send to Selected Handhelds. Locate the OS on your 
computer and send it. 
To download the latest handheld OS, go to education.ti.com. 
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Activity Overview 
The following keypad shortcuts can be used to perform common functions on the TI-Nspire™ CX family of 
handhelds. Many shortcuts can also be uysed in the TI-Nspire™ and TI-Nspire™ CAS Teacher Software, 
as well as by selecting options from various menus and submenus. 
 

 
Getting Help 
Open Hints / µ 
  

Editing Text 

Cut / X 
Copy / C 

Paste / V 

Undo / Z or / d 

Redo / Y or g d 

Toggle approximate and exact results / · 

Change key to include appropriate accent ; 
  

Inserting Characters and Symbols in a Document 

Display character/symbol palette / k 

Underscore / _ 

Display math template palette t 

Backslash g p 

Manual data capture point / ^ 

Clear / . 

Caps lock / g 

Store / h 

Square brackets / ( 

Curly brackets / ) 

Display Trig symbol palette µ 

Equals symbol = 

Display pi symbols palette (π, /, θ, and so on) ¹ 

Display equality/inequality palette (>, <, ≠, ≥, ≤, |) / = 

Display marks and letter symbols palette (? ! $ ‘ “ : ; _ \) º 

Square root / q 

log / s 

ln / u 

ans / v 
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Managing Documents 

Open document menu ~ 

Open document / O 

Close document / W 

Create new document / N 

Insert new page / I 

Select application / K 

Save current document / S or / » 
  

Navigation 

Top of page / 7 

End of page / 1 

Page up / 9 

Page down / 3 

Up a level in the hierarchy / £ 

Down a level in the hierarchy / ¤ 

Context menu for selection b 

Extends selection in direction of arrow g any arrow 

  

Navigating in Documents 

Displays previous page / ¡ 

Displays next page / ¢ 

Displays Page Sorter / £ 

Exits Page Sorter / ¤ 

Switch between applications on a split page / e 

Moves focus backward within a page g e 

  

Wizards and Templates 

Add a column to a matrix after the current column g @ 

Add a row to a matrix after the current row @ 

Integration template g + 

Derivative template g - 

Math template palette t or / ; 

Fraction template / p 
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Modifying the Display 

Increase contrast / + 

Decrease contrast / - 

Power off / c 

  

Using Application-Specific Shortcuts 

Select all in Notes or Program Editor / A 

Check syntax and store (in Program Editor) / B 

Find (in Program Editor) / F 

Hide/Show Entry Line (in Graphs or Geometry) 
Go To (in Lists & Spreadsheet, Program Editor) 

/ G 

Find and Replace (in Program Editor) / H 

Insert Math Box (in Notes) / M 

Open the Scratchpad » 

Recalculate (in Lists & Spreadsheet) / R 

Add Function Table (in Lists & Spreadsheet, Graphs, and Geometry) / T 

Group/ungroup / 4 / / 6 
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Activity Overview 
In this activity, you will learn how to check the operating system (OS) on a TI-Nspire™ handheld and 
update it using the TI-Nspire™ Teacher Software. 
 
 

Materials 
• TI-Nspire™ or TI-Nspire™ CAS Teacher Software and standard-A to mini-B USB cable 

 
 
 

Viewing Handheld Status 

The Handheld Status screen displays the battery status, (OS) 
version, available space, the network (if any), and your student 
login name and whether you are logged in. 

To view the Handheld Status, press c and select Settings > 
Status. The Handheld Status dialog box opens.  

Note:   The About screen displays the handheld type and product ID. To view the About screen 
from the Handheld Status screen, click About. To return to the home screen, press ·. 

Updating the Handheld OS 

You can update the OS on your TI-Nspire™ handheld using the TI-Nspire™ Teacher Software or by 
transferring the OS from one handheld to another. OS upgrades do not delete user documents. If there is 
not enough room on the receiving handheld for the upgrade, the sending device is notified. The only time 
documents can be affected by an OS installation is if the receiving handheld has a corrupted OS. It is a 
good practice to back up important documents and folders before installing an updated OS. 

Important OS Download Information 

In the TI-Nspire™ family of handhelds, different handheld types require different operating systems: 

• The OS for the TI-NspireTM CX handheld has the file extension .tco. 
• The OS for the TI-NspireTM CX CAS has the file extension .tcc. 
• The OS for the TI-NspireTM with Touchpad or Clickpad has the file extension .tno. 
• The OS for the TI-NspireTM CAS with Touchpad or Clickpad has the file extension .tnc. 

Always make sure the TI-Nspire CX handheld is fully charged before beginning an OS download (or, if 
using the TI-Nspire with Touchpad or Clickpad, install new batteries).  

Finding Operating System Upgrades 

Your TI-Nspire™ Teacher Software has convenient links to a number of useful Texas Instruments web 
sites, including those with handheld OS updates. You will need an Internet connection and the USB 
connection cable to download and install the updates. 

111



 Checking and Updating the Operating System                                       
TI PROFESSIONAL DEVELOPMENT                                                                

 

 

©2014 Texas Instruments Incorporated 2 education.ti.com 

Using TI-Nspire Teacher Software to Update the Handheld OS 

Open the TI-Nspire Teacher Software and connect a TI-Nspire handheld to the computer using the 
USB connection cable. Go to the Document Workspace, select the Content Explorer tab, and click 
TI-Nspire™ Connected Handhelds. Multiple handhelds can be connected to the computer using 
multiple USB ports, USB hubs, or the TI-NspireTM Docking Station. If multiple handhelds are 
connected to the computer, then multiple handhelds appear in the list of Connected Handhelds. 

The connected handheld appears in the Content Window. Click on the name of the handheld to 
display battery, storage, and OS information. More detailed information appears in the Handheld 
Information window. 

 

To see if a new OS is available, right-click on the row that includes the handheld’s name. Select 
Check for OS Update. If there is a newer version of the OS available, follow the directions to install it. 
A window will inform you that any unsaved data will be lost. If you want to continue, select Yes. 
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Activity Overview 
In this activity, you will learn how to transfer a document from one TI-Nspire™ CX handheld to another. 
 
 
Materials 

• Two TI-Nspire CX handhelds 
• Unit-to-unit connection cable (Mini-A to Mini-B USB) 

 
 

Transferring a Document or a Folder 

Documents can be transferred between two TI-Nspire CX handhelds 
by connecting them with the unit-to-unit mini USB cable. The USB A 
port is located at the top of the handheld on the right side. 

 
Step 1: 

Firmly insert the ends of the mini USB unit-to-unit cable into the 
USB A ports of the handhelds. The handhelds will automatically 
turn on when the cable is plugged in. 

Step 2: 

Open My Documents on the sending handheld. 

Step 3: 

Press the £ and ¤ keys to highlight the document or folder to send. 

 

 

Step 4: 

Press b and select Send. No action is required by the user of 

the receiving TI-Nspire CX handheld. Once the transfer begins, a 
progress bar displays the status of the transfer. When the 
transfer is complete, a message displays on the receiving 
handheld. If the document was renamed on the receiving 
handheld, the new document name appears. 

 

Note:   When sending a folder from one handheld to another, the file structure in the sending folder is 
retained. If the folder does not exist on the receiving handheld, it will be created. If the folder 
does exist, files will be copied into it, with appended names added to any duplicate files. 

Note:   To cancel a transmission in progress, select Cancel in the dialog box of the sending handheld. To 
cancel a transfer from the receiving handheld, press d. The receiving handheld, however, 
cannot cancel a transfer of folders. If an error message appears, press d or · to clear it. 

113



 Transferring Documents Between Handhelds 
TI PROFESSIONAL DEVELOPMENT 

 

©2014 Texas Instruments Incorporated 2 education.ti.com 

Guidelines for Transferring Documents or Folders 

The guidelines for sending an individual document also apply to documents within folders that are sent. 

• If you send a document with the same name as an existing document on the receiving TI-Nspire 
CX handheld, the system renames the sent document by appending a number to the name. For 
example, if you send a document named Mydata to another TI-Nspire handheld that already 
contains a document named Mydata, the document you send will be renamed Mydata(2). Both 
the sending and receiving units display a message that shows the new name. 

• There is a 255-character maximum length for a document name, including the entire path. If a 
transmitted document has the same name as an existing document on the receiving handheld 
and the document names contain 255 characters, then the name of the transmitted document will 
be truncated to allow the software to follow the renaming scheme described in the previous bullet. 

• All variables associated with the document being transmitted are transferred with the document. 

• Transmissions will time out after 30 seconds. 
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Activity Overview 
In this activity, you will use the Documents and Content Workspaces of the TI-Nspire™ Teacher Software 
to transfer TI-Nspire™ documents between the computer and the handheld.  
 
 

Materials 
• TI-Nspire™ or TI-Nspire™ CAS Teacher Software  

• TI-Nspire™ handheld and standard-A to mini-B USB cable 
 
 
 

Transferring Documents in the Documents Workspace 

Step 1: 

Open the Teacher Software. Go to the Documents Workspace 
by clicking the Documents tab. 

 

Step 2: 

Connect a TI-Nspire™ handheld to the computer using the USB 
connection cable. Multiple handhelds can be connected using 
multiple USB ports, USB hubs, or the TI-Nspire™ Docking 
Station. If multiple handhelds are connected, then multiple 
handhelds appear in the Connected Handhelds panel. 

 

Step 3: 

Documents can be transferred between the computer and 
connected handhelds using the Content Explorer in the 
Documents Toolbox. Open the Content Explorer by clicking the 

 Content Explorer tab. 

 

 

Step 4: 

To transfer a TI-Nspire document from the computer to the handheld, locate the document in the 
Computer panel. Click, drag, and drop it into the handheld in the Connected Handhelds panel. 

 
Step 5: 

To transfer a TI-Nspire™ document from the connected handheld to the computer, locate the document 
in the Connected Handhelds panel. Click, drag, and drop it into the desired folder in the Computer panel.   
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Transferring Documents in the Content Workspace 

Step 6: 

Go to the Content Workspace by clicking the Content tab. In the 
Resources panel, select Connected Handhelds. 

 

Step 7: 

The connected handheld appears in the Content window, along 
with battery, storage, and OS information. To view the documents 
on a connected handheld, click the name of the handheld.  

 

 

Step 8: 

Locate a TI-Nspire™ document on your computer by browsing Computer Content in the Resources 
panel. Send the document by dragging and dropping it to the connected handheld. The document can 
also be sent by right-clicking it and selecting  Send to Connected Handhelds.  
 

 
 

Step 9: 

The Transfer Tool window appears with the current 
document. Documents can be added to or removed 
from the transfer list, and the destination folder on the 
handheld(s) can be edited or changed. To send the 
document to the handheld(s), click Start Transfer. 
Once the Status tab indicates that the transfer is 
complete, click Stop Transfer. 
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Activity Overview 
The Press-to-Test feature enables you to quickly prepare student handhelds for exams by temporarily 
disabling folders, documents, and select features and commands. Steps 1-7 in this activity enables 
Press-to-Test. To disable Press-to-Test, you will need to follow Steps 8-9 using either an additional TI-
Nspire handheld or a computer with the TI-Nspire Teacher Software. 
 
 

Materials 

• TI-Nspire™ handheld-to-handheld or handheld-to-computer USB connection cable  
 
 
 

Step 1: 

To enable Press-to-Test on the TI-Nspire™ with Touchpad and 
TI-Nspire CX™, first ensure that the handheld is turned off. Press 
and hold d and c until the Press-to-Test screen appears. 

Note:   To enable Press-to-Test on TI-Nspire™ with Clickpad, 
press and hold d, c, and w. 

 
Step 2: 

By default, Press-to-Test disables pre-existing Scratchpad data, 
documents, and folders as well as many other functionalities of the 
handheld. The angle settings can be changed by pressing ¢, 
selecting the appropriate setting, and pressing ¢ or ·. 

By default, all of the commands and features listed are disabled. 
To enable a feature or command, uncheck its box. Keep all boxes 
checked, and enter Press-to-Test by clicking Enter Press-to-Test. 

 

 

Step 3: 

Once the handheld is in Press-to-Test mode, the handheld 
reboots. A dialog box confirms that the handheld is in Press-to-
Test mode and the restrictions are listed. Click OK. 

Step 4: 

When in Press-to-Test mode, the LED at the top of the handheld 
begins blinking. Green indicates that all restrictions are selected 
(default), while yellow indicates that one or more restrictions are 
unselected. During the initial reboot, the LED alternates between 
red and, depending on the restrictions, either green or yellow. 
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Step 5: 

Create a new document, add a Geometry page, and press b. 

Since geometry functions are limited, observe that the Measurement, 
Construction, and Transformation menus are not accessible. 

Note: The lock icon at the top of the screen indicates that the 
handheld is in Press-to-Test mode.  

Step 6: 

Add a Calculator application by selecting ~  > Insert > 
Calculator. Type cot(π/2) and press ·. Since trigonometric 

functions are limited, an error message appears. The dialog box 
tells students how to access additional information about the 
restrictions. Click OK. 

 

Step 7: 

Select c > My Documents. While in Press-to-Test mode, a 

Press-to-Test folder appears in My Documents. All other folders 
and documents present on the handheld before Press-to-Test 
mode was entered are inaccessible. 

Step 8: 

To exit Press-to-Test mode, connect two handhelds using the 
handheld-to-handheld USB connection cable. Then select ~ > 

Press-to-Test > Exit Press-to-Test. The Exit Press-to-Test option 
appears regardless of whether the other handheld is in Press-to-
Test mode. 

Press-to-Test can also be exited with the TI-Nspire™ Navigator™ 
Teacher Software. Once a class has been started, students can 
select ~ > Press-to-Test > Exit Press-to-Test. 

 

 

Step 9: 

Press-to-Test can also be exited with TI-Nspire Teacher Software or 
TI-Nspire Navigator Teacher Software by creating a document named 
Exit Test Mode.tns, and transferring it to connected handhelds.  

Note:    The name of the TI-Nspire document must be spelled exactly as it is above. 

Go to the Tools menu and select Transfer Tool. Click Add to Transfer List and select 
Exit Test Mode.tns. In the Edit Destination Folder, enter the name of the folder Press-to-
Test, and click Change. Then, click Start Transfer. 
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The eight Common Core Mathematical Practices that students should understand and enact in doing 
and thinking about mathematics are: 

1. Make sense of problems and persevere in solving them 
2. Reason abstractly and quantitatively 
3. Construct viable arguments and critique the reasoning of others 
4. Model with mathematics 
5. Use appropriate tools strategically 
6. Attend to precision 
7. Look for and make use of structure 
8. Look for and express regularity in repeated reasoning 

 
In particular: 

1. Make sense of problems and persevere in solving them 
• consider analogous problems, special cases and simpler forms  
• transform algebraic expressions or change the viewing window to obtain information needed 
• use concrete objects or pictures to help solve a problem 
• explain correspondences between equations, verbal descriptions, tables, and graphs or draw 

diagrams of important features and relationships, graph data, and search for regularity or trends 
• make conjectures about the form and meaning of the solution and plan a solution path rather than 

jumping into a solution 
• check answers to problems using a different method 
• monitor and evaluate progress and change course if necessary 
• understand and compare different approaches 

 
2. Reason abstractly and quantitatively 

• represent a given situation symbolically and manipulate the representing symbols 
• stop and think about what the symbols represent in the context of a given situation 
• reason with quantities and about relations among quantities 
• consider the units involved 
• attend to the meaning of quantities, not just how to compute them 
• know and flexibly using different properties of operations and objects 

 
3. Construct viable arguments and critique the reasoning of others 

• make conjectures and build a logical progression of ideas 
• use stated assumptions, definitions and previously established results in constructing arguments  
• determine domains to which an argument applies 
• analyze situations by breaking them into cases 
• recognize and use counterexamples 
• compare the effectiveness of two plausible arguments 
• distinguish correct reasoning from that which is flawed and explain any flaws 
• justify conclusions and communicate them to others 
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4. Model with mathematics 
• write an equation to describe a situation 
• apply mathematics to solve problems arising in everyday life, society, and the workplace 
• identify important quantities in a practical situation and map their relationships using diagrams, 

two-way tables, graphs, flowcharts and formulas 
• make assumptions and approximations to simplify a complicated situation 
• interpret mathematical results in the context of the situation and reflect on whether the results 

make sense, improving the model as necessary 
 
5. Use appropriate tools strategically 

• make sound decisions about using tools, recognizing both the insight to be gained and their 
limitations 

• use technology to visualize the results of varying assumptions, explore consequences, and 
compare predictions with data 

• use technological tools to explore and deepen understanding of concepts 
• identify relevant external mathematical resources and use them to pose or solve problems 
• analyze graphs, functions and solutions generated by technology 
• detect possible errors by using estimation and other mathematical knowledge 

 
6. Attend to precision 

• communicate precisely to others 
• use clear definitions in discussion and in reasoning 
• state the meaning of symbols used, specifying units of measure, and labeling axes 
• calculate accurately and efficiently 
• note the assumptions made 
• express answers with an appropriate degree of precision 

 
7. Look for and make use of structure 

• look closely to discern a pattern or structure 
• see complicated things (such as algebraic expressions or functions or a histogram) as single 

objects or being composed of several objects 
• recognize and use the strategy of drawing auxiliary lines to support an argument  

 
8. Look for regularity in repeated reasoning 

• notice if calculations are repeated 
• look for general methods and for shortcuts  
• evaluate the reasonableness of intermediate results 

 
 
 
Common Core State Standards for Mathematics. (2011). 
www.corestandards.org/assets/CCSSI_Math%20Standards.pdf 
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TI-Nspire™ Technology 

Approved for Tests 
TI-Nspire™ CX 

TI-Nspire™ w/Touchpad 

TI-Nspire™ CX CAS 

TI-Nspire™ CAS w/Touchpad 

SAT* • • 
AP* • • 
PSAT/NMSQT* • • 
ACT* •  
International Baccalaureate •  
Praxis™ • • 
Texas STAAR® Grade 8 •  
Texas STAAR® Algebra •  

 
 
Graphing Technology 

Approved for Tests 
TI-84 Plus C Silver Edition 
TI-84 Plus Silver Edition 

TI-84 Plus, TI-83 Plus 

TI-89 Titanium 

SAT* • • 
AP* • • 
PSAT/NMSQT* • • 
ACT* •  
International Baccalaureate •  
Praxis™ • • 
Texas STAAR® Grade 8 •  
Texas STAAR® Algebra •  

 
 
* SAT and AP are registered trademarks, and SAT Reasoning Test and SAT Subject Tests are trademarks of the College 
Entrance Examination Board. PSAT/NMSQT is a registered trademark of the College Entrance Examination Board and 
National Merit Scholarship Corporation, neither of which were involved in the production of, nor do they endorse this 
product. ACT is a registered trademark of ACT, Inc., which does not endorse this product. Policies subject to change. Visit 
www.collegeboard.com and www.act.org. 
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